Admin PW not working after FW Upgrade for NK Storage?

I had a strange behavior after upgrading to new Firmware - bug or feature ?
While the User key was still the same, neither the old Admin key nor the factory default for Admin was working any longer.

And you guess it right: within seconds the 3 tries are gone …
[ all under macOS 10.12.4, Nitro App 1.0 ]

==> So is that a feature and what will be the Admin password then ? Or just strange :smiley:

Solution : Again I pull up the Ubuntu VM and tried to reset the NK Storage Key.

GnuPG 2.1 as gpg2 --card-edit ==> admin ==> factory-reset started, but finished with an error

GnuPG 2.0 as gpg-connect-agent <nitrokey-reset.txt worked well and rested Admin and User try-counter and PW to Factory Defaults

Hint: The Firmware Password is NOT reset ! Just in case one thinks so …

What firmware versions have you used during upgrade? 0.44 -> 0.45?

I used 0.45 ( think that is the latest ?) :thinking:

Yes, the v0.45 is the latest. But what was the previous firmware on the device, from which were you updating?

I think it was 0.42 what was the original FW. As it is a bit more complicated to do FW updates on a Mac, I was not able to do the earlier updates. I assume things like the boot loader have not changed during 0.4x ?