App on El Capitan does not detect Nitrokey

Hi guys,

I got the Nitrokey Pro last week. Set up on OS X Yosemite went smooth but it looks like drivers are not up to date yet for El Capitan.

In the end I managed to get OpenSC and pcscd working and Firefox and GPG to connect but the nitrokey app still does not detect the dongle when connected.

Any tips on what to look for to resolve this?

same here :exclamation:

For us the Nitrokey App is working on El Capitan. Can you confirm that Nitrokey App worked with Yosemite and stopped working after updating to El Capitan?

i installed the app only on El Capitan and it does not work, after the instructions from the other thread at least the command-line tools detect the nitrokey



is there anything we can do/try(?), or are we left alone?

thank you!


I can confirm that the Nitrokey app detected my Nitrokey on 10.9 but does not detect the Nitrokey now that I’ve upgraded to 10.11.

This is on two different machines. MacBook Pro 2011 with Yosemite and MacBook Pro Retina 2015 with El Capitan. On El Capitan I installed Ludovic Rousseau’s CCID driver and opensc-tool -l recognizes it as well as Firefox, but not the Nitrokey app.

I get that the Nitrokey App needs to be improved for MacOS. We are currently refactoring the App which is why MacOS improvements need to wait a bit. At the same time your patches are very welcome!

I’ve got a brand new Macbook pro with El Capitan, wasn’t able to even get as far as installing ccid-openkms, incompatible version.

Using a just arrived nitrokey pro.

Is there any ETA for when you expect to have it OSX El Capitan compatible?

I tried using a virtual machine but VirtualBox is giving me an error about the device being “in use by someone else.” Is it possible to use the Nitrokey with VirtualBox?

You could try unmounting the nitrokey using the diskutils on OSX and see if that helps.

Unfortunately we don’t have an ETA for a new Mac OS client yet. Frankly, the reason is that we don’t have sufficient Mac OS experience and we are looking for a developer with Mac OS skills. If you guys could help, please send us an email.

Regarding VirtualBox: You can use the Nitrokey as any other USB device. Our experience with VirtualBox is that it does work very poorly and unreliable with USB devices (of any kind). In the past they had a proprietary USB driver which could be installed manually and worked a bit better. In general we recommend to use any other VM solution but not VirtualBox.

I haven’t fully tested yet but it seems that with the new El Capitan update the app(0.2) works fine.
I tried:
[ul]changing user and admin pins[/ul]
[ul]setting up OTP[/ul]
[ul]using the password safe[/ul]

Things I haven’t tried:
[ul]Setting up OpenPGP keys[/ul]
[ul]Installing certificates[/ul]

Things I noticed:
[ul]sometimes the key will temporarily disconnect[/ul]

I hope this helps anyone?
I encourage users who couldn’t detect the keys before to try again and post here with updates.

Works for me too: OSX El Capitan, 10.11.2, Nitrokey app version: 0.2, firmware version: 0.7

Password safe works too.

For the record I thought I should also mention that I am NOT using the custom drivers listed on the website but the standard CCID drivers instead.

Thanks guys for the heads-up!

I also confirm that after updating to 10.11.3 the Nitrokey app connects again.

Not related to the App in particular but to Mac OS in general:

Martin Paljak’s CCID driver for Mac OS X has been updated:
See also: … rades.html