Doesn't seem to work under Fedora 25

Well, following the instructions for installation of the Nitrokey app under Linux was’nt much fun. There is absolutely no libccid package in Fedora’s repositories and it took me some time to find out that pcsc-lite-ccid could probably the right substitute. Otherwise I followed the instruction step by step, but I didn’t succeed.

The Nitrokey app starts and informs me when the Nitrokey is connected, but otherwise it’s just running in the background without a glimpse of a GUI: no chance to change the admin PIN oder user PIN, no chance to access the Nitrokey at all.

I didn’t expect the usage of the Nitrokey to be rocket science. For now I struggled half a day with it. I’ll give it one more day and then I give up.

Which window manager are you using?

Should be Mutter (Gnome/Wayland standard).

Hi Badger!

I am a bit confused. I have just made a fresh install of Fedora 25 (workstation DVD iso) on VirtualBox VM. Both GnuPG and Nitrokey App worked out-of-the-box for me. Could you point out which instructions have you used?

App can be reached by Tray menu, which is in left bottom corner of the screen in default setup. I have installed it using sudo dnf install nitrokey-app and checked both default and classic Gnome. In terminal command gpg2 --card-status returned correct information about my stick (Storage v0.38).

Thanks so much for your help! That’s it, (non-existing) problem solved.

I use Fedora for some years now, but I never made use of the tray for a simple reason: I employ the Gnome extension “Dash to Dock” and the dock normaly overlays the trigger point of the tray. (And actually the light grey icon of the Nitrokey app isn’t easy to detect in the light grey tray.)

Thank you once again.

I am glad it works! :slight_smile: We can learn from this something too. On first run we can show a message that the Application is available through Tray. And the icon might be in other colour possibly.

Regarding pcsc-lite-ccid package, could you tell me why have you needed it?

Registered issues:

  1. Tray icon is not always visible
  2. Show a message on first run about the tray

Actually, I don’t know, whether I really did need it, I only tried to follow the instruction for Linux, step 1. So I checked and found out that the package libccid was’t installed on my computer – and pcsc-lite-ccid seemed to be the appropriate substitute from the Fedora repositories.

I see. I guess you mean Installation guide. We will update it. Thank you!