Error while updating firmware of Nitrokey Storage


I wanted to update Nitrokey Storage from version 0.52 to 0.54 on Windows 10 2004. After going to update mode I get this log:

2.499]: Nitrokey Storage detected in Update mode.
[ 4.002]: Set file C:/Users/Grzegorz/Downloads/storage-firmware-V0.54-0-g0b1ed2d.hex
[ 8.786]: *** Update procedure started
[ 8.796]: Installing USB drivers …
[ 8.803]: USB drivers installed.
[ 8.807]: Connecting to device …
[ 8.815]: WARNING: Device connection has failed (code 1).
[ 8.818]: Device could not be connected. Cancelling the procedure.

Nitrokey is not being discoverable by OS and I cannot update the firmware. What should I do?

Hi Gregorz, did you find a way to detect your nitrokey?

If not let me know, and and we will try to debug it.

Actually not, I cannot update the firmware and it is still visible as working in update mode.

I see. if it is okay with you, I will try to reproduce the update process on Windows 10, and let you know.

Just to be on the safe side, I assume you followed the instructions here. For manual update on Windows there also these instructions.

Yes, I followed the instruction mentioned there. I switched Nitrokey to update mode, downloaded update tool and newest firmware. Unfortunatelly, I get the error presented above. OS is Windows 10 2004 19041.508.

1 Like

Hi Grzegorz, did you try to set up the key on a different machine, and/or on a different USB slot on the same machine?


Log shows, that despite installing libusb drivers, the update application could not connect to the device being in the Update Mode, thus it had to stop early.
My quick ideas:

  1. Run the update process once again (after OS restart). Chances are it will execute this time.
  2. Install libusb drivers by hand. See Update application has it embedded, however version could be outdated, and the drivers are not accepted anymore in the latest Windows 10 build.

@nitr0z: Could you retest this please?


unfortunately, after installing drivers from error is still the same. Cannot update and stick ist still in download mode.

@szszszsz @nitr0z - any help/update?


I should have a working solution tomorrow. Sorry for the delay.
In the meantime as a workaround please use other operating system than Windows 10 2004, if possible.

Good evening,

Finally reproduced the environment (version 2004, OS 19041.508), however the Nitrokey was successfully updated to the firmware v 0.54.

I used this guide, and it worked (for me) as documented.

I second this, as I would also recommend to test the Nitrokey on a different machine/OS.