Firmware update - cannot unlock hidden volume (wrong password message)


#1

Hello!

After I managed to update the firmware to 0.50, I tried to open my hidden volume - but get the message that the password is wrong. I have the NK stoarage, am using the latest app, and can unlock the encrypted volume, but accessing the hidden volume is not possible - neither with the default nor with my self-set password.

Any hints what to do are much apprechiated!


#2

Hi dunno,

so your encrypted volume is normally accessible and only the hidden volume can not get loaded?

Because in general I would guess that the firmware upgrade did harm to the storage. This can happen as stated on the firmware upgrade guide. But if the encrypted storage is not damaged, one would expect the hidden volume to work as usual. But I can not rule out the possibility that there still is a damage.

Is something else behaving strangely? From what version did you upgrade from? What is the exact error message (may provide screenshot).

Kind regards
Alex


#3

Hi Alex,

right. I can access the unencrypted part as well as unlock the encrypted part. I updated from the previous versions (both, firmware and app).

By the time I have written my first post, the messge was “falsches Passwort”.

hidden-storage_a_2018-02-19

and the hidden volume couln’t be neither unlocked nor accessed.

When I try to access it now it says I have to unlock the encrypted volume first. But I unlocked it already.

hidden-storage_2018-02-19

Trying to lock the encrypted part again results in no activtiy at all, i.e. the unlocked encrypted part can not be locked, but I don’t receive any messages. Locking the whole devices worked.

Trying to reproduce either of these two scenarios resulted in the first error (wrong password)

So, I wouldn’t mind resetting something, but I would like to know first if I could just configure the hidden volume ("verstecktes volumen einrichten) or if I had to do something else or instead.

Thanks a lot!


#4

Hi @nitroalex !
Re my last post: is there an option other than resetting the hidden volume to get it working again?
Thanks!


#5

Hi,

I am very sorry for the rather late response!

I would recommend to reset the whole device and not only reconfigure a hidden volume. As you can not be sure what went wrong while upgrading the firmware, resetting the storage (“destroy encrypted data”) would be the best option in my opinion. Please be aware that this affects not only the storage but also the password safe and the saved OTPs.

You can try to just to reconfigure a hidden volume, though. It may is worth a try. It should be enough to just configure one hidden volume again the same way you did before. This should override any data and setting previously saved on this locations/slots.

Kind regards
Alex


#6

Thanks a lot, Alex, this helps.
Regards!


#7

@nitroalex and don’t worry about ‘late’ answer :wink: