How to use nitrokey-app in Ubuntu w/ Gnome>3.26


#21

@Herve5
Sorry for the delay. I have not found the cause yet. I do not think we have tested it on 4.19 yet, so this might be a reason.

I thought the volumes will mount themselves without the Lock->Unlock actions run in the Nitrokey App. Is that not the case?

@nitroalex Could you check that on the latest kernel - 4.19 - please? Just tested on Fedora with 4.18.16-200.fc28.x86_64, and it has not reproduced.


#22

Yes, they do mount themselves without any unlocking action (I did this because earlier on I was suggested to lock/unlock).
Now, there is a very long delay before the mounting, really many seconds, which was not the case before. Then the two identical read-only volumes appear simultaneously.


#23

I tried again with newer Kernel. Neither on my Arch system nor an a Ubuntu 18.04 with Mate desktop I could reproduce the issue. The encrypted volume is unlocked as expected. I am sorry.


#24

Sorry for delay. Could you try to use other window manager, than Mate, for test purposes? Eg. Gnome Shell.

Perhaps the pcscd has activated again. Could you paste please the result of the following here?

systemctl status pcscd

Sorry it takes so long. Since we cannot reproduce the issue locally, it is hard to pinpoint the cause. If all fails, the clean installation of the OS might be needed (since @nitroalex confirms it works on the fresh setup), though it would be best to avoid it of course.


#25

for pcscd, here is what I get:

~$ systemctl status pcscd
● pcscd.service - PC/SC Smart Card Daemon
   Loaded: loaded (/lib/systemd/system/pcscd.service; indirect; vendor preset: e
   Active: inactive (dead)
     Docs: man:pcscd(8)
lines 1-4/4 (END)

For changing the windows manager, which is less obvious to me, I just switched from “Marco” to “Compiz” with no improvement : Compiz indeed worsens things, the Nitro app loses its buttons. But I don’t see a way to switch to Gnome for the moment (I have not the choice button at login, I try to get some help).

Don’t apologize for the delay, it’s me that bring trouble! :blush:


#26

There should appear a engine gear after choosing a username in the login manager (or after typing in the password :thinking:) or some of this kind to switch the desktop-manager. But if you installed the mate desktop right away from a special installation medium you may don’t have another DE at all. In this case I propose to install

sudo apt update && sudo apt install gnome-desktop-environment

and try again to change the DE.

Kind regards
Alex


#27

Thank you NitroAlex!
I did install gnome before (with tasksel) but I still don’t have the famous engine gear aside my username in the login manager :frowning:
Just tried again with apt, but not better…


#28

Hi!
Just wanted to explain the rationale behind changing the window manager, so perhaps you would find any other way around.

I guess that one of the cause for doubled mounting is behind a file manager used. That is rather a blind shot, than tested solution, but I am out of other ideas unfortunately and we cannot reproduce it ourselves. We observed similar issue in the past, but it stopped to occur.

I remember you are using 4.19 kernel. Could you boot 4.18 (or older) for the test purposes and test once again? I know that @nitroalex tested that already, but perhaps it will change the case on your side.


#29

Thank you szszszsz!

in fact I left on a 3-days holiday this week-end, with the Linux machine but I forgot the Nitrokey :frowning:
But, I remember this issue was already there before I upgraded the kernel to 4.19.

I’ll try getting back to an earlier kernel on Monday, but I am pessimistic. What is clear on the other hand is, I certainly messed the ordinary Ubuntu system when upgrading from 16 to 18.

(Indeed I am considering switching to the plain Debian distribution, but for a low-level guy like me this means a complex transfer activity, most certainly with the help of specialists that are seldomly available, etc. -even just installing a parallel Debian system on my second internal HD is a bit frightening for me…)