Insert key disable


#1

Hi,

I played with my new nitrokey start a little, copied my private key over to the nitrokey (and I have a backup of .gnupg before that). I then decided not to use it right away, removed the nitrokey, restored the .gnupg directory just in case. I played with the nitrokey a little more in another environment, reset it etc.

And now every time I want to sign a mail with Thunderbird or GNU Emacs it asks me to insert the nitrokey.

 Please insert the card with serial number

I tried to sign something via the command line and everything is fine. I tried to logout and login again to make sure no agent was still holding something .There must be some leftover somewhere that makes Thunderbird believe it needs the nitrokey. I have absolutely no clue where to look to resolve that and I would be very grateful if you could point me in the right direction.

Thanks in advance

P.S. I’m using Debian GNU/Linux stretch


#2

It turns out the ~/.gnupg backup I used was not actually the backup I should have used and contained the modified files. My bad !