macOS OpenSC overides GnuPG

I followed your instruction under and installed and init the card with GnuPG. After that I installed OpenSC from your link ( Version 0.16.0 ) .

After the OpenSC installation neither gpg/gpg2 --card-status nor the Nitro-app (ver 0.5.1) worked any longer. While opensc-tool --what-ever worked very well. Now, not your fault - just a hint.

I uninstalled OpenSC and everything works again :mrgreen:

Parallel access of applications to Nitrokey (and to smart cards in general) is troublesome. As a best practice, between GnuPG, OpenSC and Nitrokey App, exit the applications which you don’t use at the moment.

To be honest: I think “Exit” is not enough: I was not running GnuPG in parallel. I assume the driver for OpenSC “grabbed” the device and so GnuPG was no longer able to get access. Only after removing the OpenSC installation I was able to use GnuPG again.
Now saying that , GnuPG has also announced, that they have some trouble with mail under macOS Sierra. So maybe this will be solved by them in the future. :wink: