New nitrokey not detected by app


#1

I have just received a new nitrokey start. I am trying to set it up, but am having trouble getting it properly working. I have tried both a debian stretch and a ubuntu bionic system

First action was to install the nitrokey app, the version I installed was v1.2.1. This didn’t work at all, because it only created a notification saying “Nitrokey app active”, but there was no way to get at the window, which is apparantly a bug with this version if you have no tray.

I then decided to compile a more recent version from source. Checked out the repo, selected the v1.3.2 branch and built a package. This did initially fail because the file data/41-nitrokey.rules is missing from the repository. I then copied it from the installed files from the previous version and managed to build and install the package. Now I actually get a window. It doesn’t work, however, since it shows “nitrokey is disconnected” and all the options are greyed out.

gpg does seem to recognize the device alright. gpg --card-status shows some output and a red led on the device flashes shortly.

Since I also read somewhere that these problems sometimes can be fixed with a firmware update, I have tried this by cloning the repository and executing the commands in the README. I am trying the following command:

./upgrade_by_passwd.py ../prebuilt/RTM.5/regnual.bin ../prebuilt/RTM.5/gnuk.bin

This results in the following error:

*** Could not proceed with the update. Please close other applications, that possibly use it (e.g. scdaemon, pcscd) and try again.

It does not matter whether I try this with, or without, sudo. While there is an scdaemon process, killing it doesn’t make the least bit of difference.

What can I do t start using my nitrokey?


#2

Following instructions found in some other thread, I started the app in debug mode, using nitrokey-app --dl 3. Running this way, I see a Throw: Device not initialized message appear after a few seconds.

This is most likely why the device isn’t working, though I have no idea how to fix it.


#3

Hi,

the Nitrokey Start is not working with the Nitrokey App. It may is in the future to ease change of PIN and generation of keys. The Nitrokey Start has no Password Safe, OTP functionality or encrypted storage, but that is what the App is for.

If gpg --card-status does work well, you are fine. The upgrade attempt may did not work, because you used GnuPG before. As GnuPG blocks the device for exclusive use, the upgrade script couldn’t access the device anymore. Just unplug the device and try again.

But you probably already have the newest firmware anyway. Please have a look at out start instructions instead.

Kind regards
Alex