Nitrokey 3C Linux OpenPGP card not available


On two separate Linux (Manjaro Linux & Fedora) machines, I have not gotten GPG able to see my Nitrokey 3C.

I have loaded the udev rules. I have been able to upgrade the firmware to v1.0.3 with pynitrokey. When running

udevadm info --attribute-walk --path=$(udevadm info --query=path --name=/dev/hidraw5) 

I can see the Nitrokey 3c listed

Yet, when I run: gpg --card-status I get:

gpg: selecting card failed: No such device
gpg: OpenPGP card not available: No such device

GPG version on Manjaro is: v2.2.36
GPG on Fedora is: v2.3.4

I have tried rebooting, I have tried to always use pcscd.

Nothing seems to work. Not sure what I can do to actually use this Nitrokey

The gpg applet is in development right now.

Während in der Backend Entwicklung bezüglich dem Secure Element (SE050) bereits viel passiert ist, ist jetzt auch die OpenPGP Card in aktiver Entwicklung. Hierzu wird es in naher Zukunft Demos / Testfirmware geben, die wir sicherlich hier ankündigen werden.

Right now FIDO2 is working.

Thanks for the reply.

I guess I hadn’t realized the upstream GPG agent wasn’t compatible with the Nitrokey 3c.

Nitrokey 3’s upstream does not have GnuPG support either. Or do you mean something else?