Nitrokey FIDO U2F: Chromium works, but Firefox 60.0.3 fails


#1

Hi there,
is this combo working for everybody except me? Using Chromium on the same box works flawless. Any pointers? I’m getting this error:


#2

As a sidenote: I have enabled u2f in Firefox’s about:config as outlined in the guide over @ https://www.nitrokey.com/documentation/installation#p:nitrokey-fido-u2f&os:linux yet Firefox throws out the error shown in the initial post.


#3

Hi,

is this initialization or logging in a already initialized account?

What system are you using? Anything else that could help to reproduce this? Plus, please try it with disabled Add-on etc. to make sure nothing else stops Firefox from working (e.g. "menu -> help -> restart with Add-ons disabled¨).

Kind regards
Alex


#4

Just logging in. Initialization of the token and tying to my account was already done in Chromium. It was a flawless experience. The Nitrokey FIDO U2F replaces the deskphone calls in my case that I’ve had to deal with for years.
I’m on Mint 18.3 x64.
I’m logging into a GAFE/GAPPS/business google account.
I was suspecting my browser extensions already, but I run the same set of 4 extensions in Chromium as well). Nonetheless I disabled them temporarily, but it didn’t work. Let me try completely disabling them as you suggested.


#5

Nah, doesn’t work either. Same error.
Any ideas where to look for logs to get an initial idea what’s going on here?


#6

I don’t know either. You could try the vanilla version of Firefox. Maybe the reason is something Mint does when packaging Firefox.

You just need to unpack the downloaded file and may make it executable to test it.