NitroKey Pro 2 Linux Login with PAM Issue


I have no success in setting up PAM with my nitrokey pro 2.
I followed the documentation on the subject.

I run Arch, with poldi and RSA 4096 keys
I do my test with sudo auth (to avoid major system failure)

The only result i get is :

sudo pacman -Syu
scdaemon[34495]: ccid open error: skip
scdaemon[34495]: detected reader ‘Nitrokey Nitrokey Pro (0000000000000000000099DB) 00 00’
Waiting for card for user arch'... scdaemon[34495]: ccid open error: skip Trying authentication as user arch’…
Serial number D2760001240103030005000099DB0000 is not associated with user arch
scdaemon[34495]: scdaemon (GnuPG) 2.2.32 arrêté
[sudo] Mot de passe de arch :

Does someone have a clue on what’s happening ?


Can you take the scdaemon logs, as described here?

Thanks for the answer.

My problem evolved because I realized I worked with the wrong files…

Because after poldi install I only get files in /usr/share/poldi/ and I used these files.

After moving to /etc/poldi my issue evolved (in a good way I hope) and is similar to this 2019 topic Problems using Nitrokey Pro for Linux pam authentication

My result is being prompt with pin but when I enter the pin I’am asked again for pin again again and again.

sudo pacman -Syu
Waiting for card for user `arch'...
Trying authentication as user `arch'...
Please unlock the card

Number: 0005 000099DB
Holder: arch
Please unlock the card

And when I miss-type the PIN I got no other result

Result of scdaemon.log

2022-04-12 21:21:31 scdaemon[115234] detected reader 'Nitrokey Nitrokey Pro (0000000000000000000099DB) 00 00'
2022-04-12 21:21:34 scdaemon[115234] DBG: asking for PIN '||Please unlock the card%0A%0A^^Number^_: 0005 00009    9DB%0AHolder^_: arch  '
2022-04-12 21:21:44 scdaemon[115234] le rappel du code personnel a renvoyé une erreur : Commande IPC inattendue

Could someone with a working Linux PAM login describe me, how he sets up his PAM and/or what is the working behavior, to help me troubleshoot this issue ?