Nitrokey Pro, HOTP Keepass and Android

Hi together,

I’m just got a NitroKey Pro and using it for Keepass 2.x on WIidows.
Till yet i was used to open the key Database on my phone too, just secured by the password.
Since Nitrokey Pro I’m using the HTOP Mechanism (accoridng to the manual provided by Nitrokey)

On Android i use KeePassDroid. Is there any way to make the Nitrokey and KeePassDroid work?
I guess i would need a Android Keepass Version supporting the HTOP Plugin?



I do not know KeePassDroid, hence I cannot help you directly. As far as I know, HOTP plugin is available at the moment only for Keepass 2.x for Windows. Perhaps you could request a port of it to Android on the project’s issue page.

As for the communication with the device, it is possible currently on Android to use the smart card feature of the device (e.g. with OpenKeychain). We do not have any application for getting TOTP/HOTP codes on Android yet, but the protocol and communication library are open and anyone could implement it.

Bottom line is, currently it is not possible to open a password database which is secured with HOTP. At least as far as I know.

Do I understand correctly from the above that Keepass on Linux won’t work with Nitrokeys?

It’s about KeePass on Android only. Using Nitrokey with KeePass2 works.

Hi Hervé!
Just to clear this out, Keepass has a couple of forks which you could use on Linux, e.g. KeepassX or KeepassXC. Since the original Keepass2 is written in C#, it is possible to use it as well on Linux through Mono.
The mentioned HOTP database locking feature is implemented as a separate open-source Keepass2 plugin, without any direct communication to the Nitrokey devices. It is possible other projects could adapt it to their codebase and perhaps they would be willing to, if asked (e.g. through their issues’ page).

Thank you szsz!
I went to explore these KeepassX and KeepassXC, they both explicitly announce not supporting plugins. I fear I am back to mono unfortunately. I’m still exploring in case there is an Ubuntu reasonable version but it’s a bit unclear to me…
This is all the more unfortunate as indeed I just tried the HOTP plugin on my work computer, and this worked instantly!

1 Like