Nitrokey3 1.4.0 gpg2 card status no device found

I have a Nitrokey3 (USB-C) with firmware version 1.4.0. I run gpg2 --card-status, but it tells me no device found.
I can use the key for FIDO2 authentication without issues. I tested also with another NK3 (USB-C) on 1.4.0 and the situation is the same.

GPG2 version 2.3.8

Any idea?

Thanks a lot!

Best regards

If that is on Linux, try restarting or stopping the pcscd service.

sudo systemctl restart pcscd pcscd.socket

Connected: Nitrokey 3A Mini: GPG, firmware v1.4.0, Nitrokey App 3, Kein passendes Gerät gefunden

Thanks a lot. Unfortunately it did not help. The FIDO2 functionality etc. works and it is firmware 1.4.0.
A PIN for the FIDO2 functionality is set (not sure - does it make a difference?).

It is OpenSUSE tumbleweed. I am not sure though what I can do to troubleshoot it.

This looks like a conflict between GnuPGP and pcscd. You can solve it by:

  • stopping, deactivating or deinstalling pcscd, or
  • configuring GnuPG to use pcscd instead of its internal driver (recommended).

I’m currently preparing a docs page for this topic with more information. You can find a draft here.

Great! Thanks a lot it works now!
Simply add in ~/.gnupg/scdaemon.conf the following content:


Then do

gpg-connect-agent "SCD KILLSCD" /bye

Then I run

gpg2 --card-status

and I can see it!