[NitroPad] Select the GPG function to perform?

Performed an OEM reset on nitropad.
Deleted old pgp key on nitrokey pro.
Created new pgp key added to nitrokey; exported public key.
Currently see this:

What’s the difference between options 1 & 2?

My goal is to start fresh with qubes.

Which option is best to reach my goal?

In addition, is there a guide for this?

Indeed both seem similar. Will check in a minute.

Links are under nitrokey.com/start:

Looking at the sources I would describe them as:

  • ’ Add GPG key to running BIOS + reflash’ - modifies currently running BIOS (this is the option you would like to use probably);
  • ’ Add GPG key to standalone BIOS image + flash’ - modifies BIOS rom file saved on the USB media (adds GPG key there).

I would think this was taken care of already by the OEM factory reset though. Was anything like this not shown during the process?

Thank you for explaining that, you’re description is helpful.

First I inserted my Nitrokey Pro on the right as shown here:
The light only blinks once and is red.

Selecting option 1:

I receive this message:

Continuing I receive this message:

I have tried all USB ports (2 on left, 1 on right) and have the same result as above each time.

How should I proceed from here?

1 Like

Thank you for the description!

  1. The red light means the device has initialized properly and has a contact with the smart card inside. This is good.
  2. Besides the Nitrokey Pro, you need any USB flash/memory device with the public part of the GnuPG key, complementary to the private part you have on the Nitrokey Pro. Using both the BIOS will be checking for the data integrity.
    Please insert the USB device with your backup of the public key.

Could you tell me why do need to add the key by hand? What error message do you get?

What do you mean? Is there another way?

Adding the GPG key to the BIOS should be taken care of while the OEM factory reset was executed I believe.
Do you have the GPG Management Menu window opened by itself on boot?

When I start the machine, the first menu I see is:

When I try and do an OEM Factory Reset, with the key inserted, I see this:

Then this:

I went with option 1 and added the public key using another USB.

Now I see this:

and when I choose Default boot I see this:

When I choose Yes, it sends me back to the NitroPad X230 Heads Boot Menu

I think I figured it out!

Got it working!

Great! Could you briefly describe what you have done to fix it?

I needed to have the public key on a separate USB plugged in, alongside the nitrokey (private key).

Unfortunately, I can’t recall exactly what I did, but I do know that this page was incredibly useful to reaching the solution:


I wish I came back here and wrote how I reached the solution those weeks ago, in case anyone else has a similar issue. I was exhausted after this gauntlet and once I resumed working with/on Qubes, doing the right thing by posting the solution on here escaped my mind.

1 Like