NK3Mini with opcard firmware: key operation not possible: Invalid data

I just tried out the opcard firmware on my NK3 Mini.
Flashing went fine:

 Successfully updated the firmware to version v1.2.2.

The next steps from the USAGE.md description:

$ gpg --edit-card --expert

gpg: WARNING: server ‘scdaemon’ is older than us (0.10.0 < 2.2.40)
gpg: Note: Outdated servers may lack important security fixes.
gpg: Note: Use the command “gpgconf --kill all” to restart them.
Reader …: [none]
Application ID …: D276000124011xxxxxxxxx
Application type .: OpenPGP
Version …: 11.50
Manufacturer …: ?
Serial number …: xxxxxxxxx
Name of cardholder: [not set]
Language prefs …: [not set]
Salutation …:
URL of public key : [not set]
Login data …: [not set]
Signature PIN …: forced
Key attributes …: rsa48 rsa48 rsa48
Max. PIN lengths .: 0 0 0
PIN retry counter : 0 0 0
Signature counter : 0
Signature key …: [none]
Encryption key…: [none]
Authentication key: [none]
General key info…: [none]

gpg/card> admin
Admin commands are allowed

gpg/card> key-attr
gpg: key operation not possible: Invalid data
gpg: error getting card info: Invalid data


I tried re-connecting the NK3Mini, that did not change anything.
Also this must be my NK3Mini as gpg could not find any card when it was disconnected.

Not all algorithms are implemented, yet.

Well the site told to follow these instructions: opcard-rs/USAGE.md at main · Nitrokey/opcard-rs · GitHub
And in there, the exact commands I entered were given, but with a non-error output. So I saw this as a but that should be reported here.

Also, I never entered any command that told the card to use RSA algorithms, it errored out before.

But now there’s a new pre-release, so I’ll try everything again.