Totp nitrokey not working (SOLVED) updated nitrokey app to 1.4.0

just bought a nitrokey storage 2

but im having a very diffecult time setting it up

totp is not working for me at all

i have tried to setup google and facebook

following the instructions on the website

but its not working

after putting in the secret key into nitrokey app and saving

it doesent generate any keys or seem save anything i put into the configuration pane in the app.

can anybody point me to a step by step guide or a video

hope somebody can be helpfull

thank you

Hi @christian_olsen!

Please provide following:

  • operating system name and version;
  • Nitrokey Storage firmware version;
  • Nitrokey App version.

Both can be found in the “About” window of the Nitrokey App, while Nitrokey Storage is connected.
In case the Nitrokey App is too old it could have problems with communication to the device.

yes of course forgot the essentials

using linux mint 20 ulayna
nitrokey storage firmware version 0.54
nitrrokey app version 1.3.2

Thank you. Nitrokey Storage v0.54 requires Nitrokey App v1.4 to work correctly, otherwise it silently skips writing the TOTP slot.
Unfortunately the App update has not reached the Ubuntu repositories, hence the latest one has to be installed either by Snap or from our PPA.
Please take a look at our download page:

new info tried update and reboot and got a new ui on nitrokey app

and i can save a slot now

ok i just figured out how it works :crazy_face:

i tried it yesterday also with the update but didnt try a restart

i can see the nitrokey app just changed to 1.4.0 after restart