Create credential: RangeError: offset is outside the bounds of the DataView

Hi, I created a PIN for my Nitrokey 3C NFC and Nitrokey 3A NFC (at I then tested creating a credential with my both of these keys at in Windows in the Firefox browser, but it fails:

Contacting token... please perform your verification gesture (e.g., touch it, or plug it in)

Note: Raw response in console.

:: "None" Attestation Format ::
Got error:
RangeError: offset is outside the bounds of the DataView

Failures: 1 TODOs: 0

However, I get green results when I try the same procedure on my android phone via NFC and via USB, Both For the Credential creation and the Get Assertion.


This should work out of the box. Do you have any special configuration?
Can you try Edge instead for this test? (assuming here it has better compatibility with exotic configurations).

Let’s try to solve the other problem first:

I looked into it. On my windows computer at home the Credential creation and the Get Assertion work now, although the time window between entering the pin and touching the device is a bit short.

I was first trying this on my corporate computer (behind a zscaler mitm proxy), this still doesn’t work, even in Edge. I was hoping to use a device like Nitrokey especially on the corporate computer because there I have to undergo several authentications a day.

I tried again, and somehow the problem went away. I don’t know what was wrong before. I’ll post here if I encounter this error again.