Encrypted E drive Nitrokey storage missing

Hi there,

Can you help. Tried to open the Nitrokey encrypted E drive today on the same Windows 10 machine in the same way and for some reason the Encrypted E drive does not show at all when typing in the unlock-encrypted-drive password. It has been working fine but today everything has dissapeared / it does not open. Can you help? Suffice to say this is extremely distressing. Are the documents still in the USB drive? How to retrieve? I am on a windows 10 lenovo machine and have had no problems whatever with this but today cannot get into the documents / encrypted E-drive.

What do you advise? There has been no “updates” to the machine that I am aware of.

Kind regards
Trevor

Hello. After you pressed Unlock Encrypted Volume, what number can be seen next to Attempts left?

If you enter your User PIN, does a notification appear with Nitrokey App/Enrypted volume unlocked?

If you open WIN+X -> Disk Management, do you see your Nitrokey volume?

Hi! Thank you so much for the post. Okay, so 3 attempts left when go to unlock the encrypted volume. When unlocking it seems to go through unlocking process- there is a sign - and after as you can see from the screengrab it seems as if the unlock has worked fine. However the E drive does not show as an option under documents next Nitrokey (D) - the encrypted (E) is missing. I took a screenshot of WIN+X - Disk Management (attached) and it does look like the E drive is there…? I’m confused, normally it appears next to Nitrokey (D) near Windows (C) but the (E) is now missing. Can you help? What do you think happened? Is there a way of attaching the screngrab?

And thank you for the post

Can’t seem to attach a file. On the Disk Management tab it says: (E) - Layout (simple) - Type (Basic) - File System (RAW)- Status (Primary Partition)…ad in the bottom boxes: Disk 2 Removable 12.84 GB Online - (E:) 122.84 GB RAW Healthy (Primary Partition)…but it does not show anywhere when clicking on Documents as an option to open like before. This bit is missing and so I cannot get to the documents. Can you help?

Would you like a screengrab? Also, why does it have “Online” beneath the Disk information in the bottom - the whole point is to have it offline. Is this normal? I can send the screenshots via a link if you would like to see them - pls let me know

Hi again, so I tried to open the E drive from within the Disk Management page by right clicking over the (E:) and pressing Open and then this sign appeared: “Location is not available. E:\ is not accessible. The file of directory is corrupted and unreadable.” I have used the Nitrokey in exactly the same way on the same windows 10 and use a proton-VPN and F-secure anti-virus application and practice online hygene. What can you recommend? Thank you again- I would be grateful

The 12.84GB matches the encrypted partition on a 16GB model. And it seems that you have the proper password to unlock the partition. That’s good!

Online/offline in this case means whether the drive is used or not. A PC may contain drives that are not activated and sleep. This is fine.

Maybe the encrypted partition was removed while the filesystem was still writing files. That way it can become corrupted and needs a filesystem check.

Please Note: As this alters the filesystem, you have to be careful and it could potentially also destroy data on the stick or make recovery more difficult. Depending on which errors need to be fixed on a filesystem, the outcome may differ. In some rare cases, a filesystem may stay corrupt and dataloss could occur.

If you have no backup of the data - and having valuable data absolutely demands for creating backups of that data - you should ask someone experienced with PCs and troubleshooting. E.g. an IT guy could create a dump of the filesystem before trying anything to fix the filesystem. That way you do not alter the data and have better recovery options.

That said, having a corrupt Fat32 filesystem is also a common thing and usually just using the filesystem check that can be run from Disk Management by selecting partition->right mouse button context menu->properties->Tools->Error checking->Check should fix it.

A corrupt filesystem may be one reason, why it does not get automatically mounted on Windows.

Another reason could be that the encryption keys got reset before in order to recover from a lost password. If that was the case, the filesystem is in a blank state and before using the Nitrokey storage, a disk format is required. When the encryption key has been rolled, the data is lost on the device anyhow and cannot be recovered.

It could also be a bug. While my Nitrokey Storage works just fine on current Windows box, there have been some issues reported that look similar. I would contact support@nitrokey.com, then.