(Heads) laptop doesnt turn on


I have a Lenovo thinkpad T430 with coreboot and heads.
After changing my password and “forgetting” it, I had to reinstall qubes but without success, so I decided to update heads to 1.3.1, unfortunately directly after flashing was “succesful” the laptop shut down and it doesnt turn on anymore. Any suggestion what happened? What I have to do now?

I dont know if thats allowed here but if someone can fix this, I would love to pay good money for that.

Do I need to reflash?

Hey @Username0193

we offer a service for reflashing Nitropads, from what you report my impression is that to revive your Nitropad there is need to reflash the firmware using an external clamp. For more information about the service please write shop at nitrokey dot com with your SOxxxxxxx.


Thank you @daringer for your answer, can you tell me the prices and how long the whole process would take?
I have external flashing tools at home but never flashed coreboot/heads, is there any good Tutorial?
The original heads/qubes documentation isnt that easy to understand for me.

Hey @Username0193,

we have a rough documentation how this is done: Firmware Update v1.4+ — Nitrokey Documentation but I strongly recommend not doing this by yourself if you are not familiar with the coreboot/heads tooling and the underlying concepts. I cannot tell the price from the top of my head, please write shop at nitrokey dot com for more information


Thank you @daringer , I managed to flash heads, it took me 15 sleepless hours of frustration but it works now :slight_smile:

1 Like

How you did that? I did flash the bios whit “nitropad-x230-maximized-v1.4.rom” instead of nitropad-x230-v1.4 .npf. Or did you not use the .rom file? I think I trashed the laptop. Updating Firmware and installing qubes 4.1 gives’s all the time unspported hardware detected message.

A flashed it externally with a SPI flasher.

Thanks I am sure now I did the wrong thing. I was hoping for an miracle, I had made an simple mistake. I could install older versions of qubes. Or other OS. If the laptop is only usable after externally flashing it. It is over. It is above my pay grade.

Hey @SvenSven

This is not good, please write shop at nitrokey dot com, we have a service to revive your laptop (using an external flasher).

But out of curiosity: Can you tell me where we should have placed the information that “you shall not use the -maximized image” so that you would have seen it? Because we really tried hard to put it everywhere, but obviously it was not enough :smiley:

Best daringer,

It was clear enough . I did read it. I just got an little inpatient and frustrated that I did get the unsupported hardware detected screen to often after upgrading whit file nitropad-x230-v1.4. I had an guy whit more knowledge of computers here this afternoon, he needed to go and I have to wait another 2 weeks before he can come back. So I just used the wrong file in an hurry and frustration, thinking when it crashes I just install another OS later. Of course I knew in the back in my mind it would not be possible. I should be more patient. -:wink:. I did read about the revive your laptop. So when I than can install version 4.1. after that without problems. I still can be happy. For sure it was clear enough stated on the website, not to flash whit nitropad-x230-maximized-v1.4.rom.

1 Like