HTTPS setup not working

I bought a nextbox, set it up for external access. I can access it fine, but every time I enter an email in the nextbox app and click “enable HTTPS”.

I get the following error message “Failed setting up HTTPS/TLS, domain and/or e-mail missing”

What does this even mean? I have a domain as i’m already accessing it externally. I’m not sure what I need to do.


I have received a new nextbox. I set up for external access: It is OK for IPv4 not for IPV6 (problem with my internet connection).

I try to enable https and I have the same message “Failed setting up HTTPS/TLS, domain and/or e-mail missing”

I downloaded the système log, and I see:

2023-01-26 10:36:32,805 [D] worker starting worker job: LED
2023-01-26 10:36:32,821 [D] worker finished worker job: LED
2023-01-26 10:36:34,575 [D] worker starting worker job: EnableHTTPS
2023-01-26 10:36:34,575 [E] jobs cannot enable tls, domain: 'XXXXXXXXXX email: ‘None’
2023-01-26 10:36:34,576 [D] worker finished worker job: EnableHTTPS
2023-01-26 10:36:38,579 [D] worker starting worker job: DynDNSUpdate

Hi Gaby, yes this is the exact same problem I’m having!

I don’t believe my ISP does IPv6 but it should work over IPv4.

I really hope Nitrokey can look into this asap, the problem is in their special app.

It makes me wonder if I should get a refund and just setup Next Cloud myself on my own raspberry pi.

see Enable HTTPS fails with email missing error, even when email address provided · Issue #61 · Nitrokey/nextbox · GitHub

After added my email adress in /srv/nextbox/nextbox.conf, it is OK.

How do I edit that file?

Some sort of FTP login?

I have enabled ssh access.
(with ssh, you have full access, and you can break the system)

In /srv/nextbox/nextbox.conf just change

email: 'None'


email: your_email

And reboot your nextbox

I’m getting a “permission denied” error when i try to save and overwrite the new file using SFTP over SSH.
Also… there is a weird file called nextbox.conf.lock in the same folder as nextbox.conf
I’m not sure if this is some sort of security feature? either way i can’t add my email. This is getting frustrating.

This is a system file, you need to have sudo permission to edit this file.
Before it is recommended to backup your nextcloud.


Thankyou Gaby,

I had to teach myself SSH, yes sudoedit nextbox.conf works now.

After RESET… IT WORKED! thank you so much.