In "emergency mode": dracut:/#

I just received my x230 with Qubes. Everything was going nicely with updates to Fedora-30. It was taking a long time and so I shut down my computer hoping to continue later. When I tried to get back on I am being taken to “emergency mode” command line with the dracut:/# prompt. It comes with 3 Warnings:

Warning: /dev/mapper/qubes_dom0-root does not exist
Warning: /dev/qubes_dom0/root does not exist
Warning: /dev/qubes_dom0 swap does not exist

At startup I have gone the route of :
https://www.nitrokey.com/documentation/nitropad-system-update
I have clicked on “update checksums and sign all files in /boot”

I have tried “default boot”

Also to unlock the disk, it wants my password 3 times before it does its checking.

When in the emergency mode there is the message : “You might want to save “/run/initramfs/rdsosreport.txt” to a USB stick or /boot after mounting them and attach it to a bug report.” I am familiar with linux command line, basic/beginner commands but don’t know how to use this one.

Anyway I have not seen this in topics/threads. Thanks for any help.

Anyway, if I can fix this, fine , otherwise I don’t mind reinstalling to how I received it at the beginning.

I found this link. Does anyone know if this would work?

Thanks

Went ahead and reinstalled Qubes. The company sent me a link to pair the Nitrokey to the Nitropad. Easy directions. It’s back working.

That post on GutHub looked quite “on the nose.” Great search, btw! Did you give it a go? Just curious if you gave it a
try before resulting to your contingency…

Which link did Nitro Support send you? I’ve been trying to keep up with reports of hiccups (like this one) and make sure can I learn/recognize similar issues should they arise with me.

Glad you’re up and running again!

Warmly,
KO

Yes I did try the other way before I reinstalled Qubes. I don’t think it worked because my disk unlocked password got messed up and I could not decrypt the drive. My opinion.

Our images are build this way.
A current image can be found here and the checksum is here.

Please mind that you need to re-configure the BIOS as well if re-installing a system. See here.

I reinstalled Qubes and Support sent me the link to pair up the Nitrokey with BIOS: