Lost encrypted volume with Nitrokey Storage

Hello all,

since a few days I have got the problem, that the encrypted volume is automatically lost or something else. When I plugin the Nitrokey Storage and unlock the encrypted volume, I can use the volume normally. After a few minutes (sometimes 5, sometimes only 1 minute, sometimes longer) the encrypted volum is no longer visible and I can only see 2 Nitrokey volumes with the Nitrokey on it. If this happens, I have to unplug the Nitrokey and plug it in again.

I already installed the latest firmware and hoped, that this will solve the problem.
But it doesn’t…

I already disabled the energy settings for the USB devices and restarted my Notebook - it’s the same.
If I plug in another USB drive, this drive is visible all the time.

I think this problem depends on a new update from Windows, is this possible?
I have the possibility to check the key with another Notebook, but this will take some time …

Has anyone else this problem?
Thanks a lot for every answer!

PS.: I‚Äôm actually using a ‚Äúnormal‚ÄĚ USB drive to save the data that has been stored in the encrypted volume on the Nitrokey‚Ķ :unamused:

Hello @dps!

  1. Can you tell, was it started happening just after the system update? I understand it started happening this week for you.
  2. Let’s list software and firmware versions just for completeness:
  • Nitrokey Storage v0.54
  • Nitrokey App ?
  • Windows ? (version and build -> see System screen, e.g. Windows 10 2004, Build 19993)

I intend to look into it in the next days. In case you would remembered anything else please let me know.

Registered as: Nitrokey-Storage#100

Things like this happened here when using a ‚ÄėNitrokey app‚Äô that was too old (on Linux) and were solved bu updating‚Ķ

I use the following versions:

  • Nitrokey Storage Firmware v0.54
  • Nitrokey App v1.4.0
  • Windows 10 Professional 64bit, Build 19042.630

Thanks a lot for your help!

Hi all,

I have an update: I have tested another Notebook and there it works since a few hours.
On this Notebook I have the following version installed:

  • Windows 10 Professional 64 Bit, Build 18363.693

So it seems like it’s a problem with a new Windows Update.
I will now send an official Service request because I need the stick working with the actual Windows version …

If anyone needs a list of the last Windows Updates - just let me know!

1 Like

Hi!
Just a quick update - new firmware release for Nitrokey Storage should be available in the next 2 days.

Hi.

Okay, sounds good!
Are there any details about this update (regarding my problem) ?

Hi. Any new details regarding the problem / software update?

Hi,
Sorry for keeping you waiting. I am finishing the tests of the firmware and will publish the release today. So far it was working for me in all cases, including latest Windows 10 build I could get on my machine - 20H2 (will check the exact build).

Please update your device to the firmware v0.55 RC1 and check again:

Update guide is at:

This release is not directly focused on the initially stated problem, however during retests no such has occurred, so perhaps this was fixed indirectly.

Thanks, update has been done.
But after 4 hours I have had the same problem … encrypted volume has been lost.

I see. Thank you for checking. This sounds like a power-saving issue indeed.
For the next release I plan to show only one volume at a time, which perhaps would solve this problem. That would be aside from checking the power saving paths.

Do you have your Notebook connected to a power source while this happens?

Yes, my notebook is connected to a power supply. USB sleep mode is also disabled … I tried several USB slots and also an USB port on my docking station - same result. And it only happens with the Nitrokey - all other USB drives are still there after 12 hours.

This post was flagged by the community and is temporarily hidden.

Hi, any new news from your side? Nitrokey is still not working …

Hi,
No updates yet unfortunately. We plan to work on this in the next 2 weeks.