Nextbox doesn't show initial setup screen

I just received my Nextbox, and… I just cannot reach the first setup screen, http://nextbox.local.
I vainly tried

  • various browsers on different machines
  • replacing the original ethernet cable with another one
  • resetting the Nextbox down to red reset LED
  • using another LAN port on my router

The Nextbox does boot up to green light.
Router is a Turris, linked to a Netgear ordinary ADSL modem.

More probably useless info :
After a while it is quite hot (8Gb RAM / 2Tb ordinary HD, although no marking on the box indicates anything whatsoever, so I cannot check this is actually the case)
When resetting there is a frightening HD scream (the kind you hear when unplugging one without parking heads); incidentally I’d like to know a way to shut the device down properly, i. e. without hearing this : will there be an option through Nextcloud?

I’m now gonna try scanning local IPs to check if I see it, but that’s a bit the limit of my computing knowledge.
Where can I find help? (I explored the NK Nextbox doc to no avail but maybe I missed something?)

Hey Herve5,

the mechanism to distribute the url http://nextbox.local within your LAN is called mDNS, which “mostly” should work, but it’s not flawless and sometimes blocked by the OS, router, switch or firewall. Please try: ping nextbox.local in a console, this should show you the IP of the NextBox, if not then likely mDNS is somehow blocked.

If this is the case you’ll have to determine the local IP of your NextBox, the easiest way might be to check for “clients” inside your internet router, then you can access your NextBox using this internal IP.

Please also check that the ethernet LEDs are blinking at your NextBox (and your switch/router), if this is not the case the physical network connection is not working.

The “quite hot” observation is good and intended, this just means the passive cooling is working and the case is giving off the heat to the environment, nothing to worry here.

Same for the HDD sound, nothing to worry, the factory-reset operation properly shuts down the NextBox.


Thank you @daringer !
The ping works :
--- nextbox.local ping statistics ---
13 packets transmitted, 13 received, 0% packet loss, time 12013ms
rtt min/avg/max/mdev = 1.220/1.492/2.383/0.312 ms
Indeed I already have a very old LAN disk (WD Mycloud) that does work locally here with ‘.local’ endings (while I never activated its WAN setting)

ok, looks good, so before the --- nextbox.local ping statistics --- there should be your local IP for the NextBox, please try using this to access your NextBox. If you find out what might be the reason for the .local url not working, please tell I’ll happily update the docs with this information!

1 Like

It worked! I just created the local admin and even a local sync with the Linux app; remote access still to come…

1 Like

cool cool, keep in mind, that the non-encrypted connection will not work once you set up tls … use one of the dns based remote access methods for best performance and user experience

1 Like

Thanks a lot!
I just tried the Quickstart remote access, is that the one you call ‘non encrypted’?
What I find with Quickstart is

  • for local connections on the LAN it is very fast, faster than WAN nextcloud servers indeed
  • for remote connections, with the url, it is very slow, much slower than ordinary nextcloud servers.
    So I presume I should use one of the other three ways!
    What worries me with these is that i’m not sure of what to use.
    Having a fix IP here, I thought I would just have to indicate it somehow, like an url actually starting with my IP, but I don’t know if that will work nor how to enter it…

I added a comparison for the different methods here: Managing Remote Access — Nitrokey Documentation just a 1st draft, will be improved.

for your specific case, if you have a static IP you can go an easy way like this:

  1. register at some dns service, like:
  2. there you choose a domain and set your IP for this domain (once logged in it’s easy to find this entry field)
  3. put the domain into the NextBox’ “static domain configuration”
  4. the next view will show you that the domain correctly resolves to your WAN-IP
  5. now open the ports 80 + 443 on your router for the NextBox (see Port Forwarding & Firewall Configuration — Nitrokey Documentation)
  6. continue and acquire your TLS certificate in the next step once the “reachability” test is green
  7. done

This is the typical use-case for a “static-ip and domain” configuration, you can also skip steps 1.-3. and use the “guided DNS” configuration, which will roughly do the same but in a more automated way.

Ah and one important addition: You cannot acquire (by definition) a TLS certificate (for remote access encryption) without a domain, thus registering some domain is always needed for a proper end-to-end encryption.


1 Like

Thank you @daringer !
Very efficient documentation. I am going to (slowly) try this :slight_smile: from now on!
I already found that as the simple manner doesn’t allow https, one cannot run video chats in the ‘Talk’ app when connected that way; it may be worth mentioning it in the doc eve if self-obvious to the knowledgeable user…

Incidentally, I checked the French translation : in the head § there is still an englisn ‘strongly’ that remains, I’d recommend to replace this we strongly recommend by the more usual french nous recommandons fortement
(also, there seems to be missing the trailing ‘italic star’ at the end of the same sentence)

Thank you again, really!

1 Like

Hi, below the output of ping, nmap and w3m What’a happens? I start NextBox today for the first time. Do I try to reset with the button on the side of the box?


$ ping nextbox.local
PING nextbox.local ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=64 time=2.34 ms
64 bytes from ( icmp_seq=2 ttl=64 time=1.15 ms
64 bytes from ( icmp_seq=3 ttl=64 time=1.60 ms
64 bytes from ( icmp_seq=4 ttl=64 time=1.12 ms
--- nextbox.local ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 1.119/1.552/2.336/0.492 ms


$ sudo nmap -sS -p 80
Starting Nmap 7.70 ( ) at 2021-07-11 10:45 CEST
Nmap scan report for (
Host is up (0.0021s latency).
80/tcp closed http
MAC Address: DC:A6:32:F7:35:8C (Raspberry Pi Trading)
Nmap done: 1 IP address (1 host up) scanned in 0.60 seconds

$ sudo nmap -sS -p 443
Starting Nmap 7.70 ( ) at 2021-07-11 10:45 CEST
Nmap scan report for (
Host is up (0.0021s latency).
443/tcp closed https
MAC Address: DC:A6:32:F7:35:8C (Raspberry Pi Trading)
Nmap done: 1 IP address (1 host up) scanned in 0.59 seconds


$ w3m nextbox.local
w3m: Can't load nextbox.local.

@aborrone You may open a new discussion here, so that you are more “visible” and knowledgeable people like @daringer will detect you better…
Do I understand correctly that if you point your browser to nextbox.local you don’t see anything?
What happens if you point it, instead, straight at the url, ?

with w3m (character browser the output it’s:

Can't load nextbox.local

The same output with firefox, dillo, chromium, ecc.
But, it’s corious that nmap say:

80/tcp closed http

the same for 443 port. Only 22 (ssh) port it’s open but I cannot access to OS because I haven’t a account on the system.

PS Sorry for my English…
PPS Tnx for your suggestion

I don’t tell you to connect to ‘nextbox.local’, I say to try connecting directly to (by typing these numbers in the browser bar)

`$ w3m
w3m: Can’t load’

the same with firefox. nmap say: no open port exept 22 how can I connect to a nextbox’s web server? I think somthing wrong in the installation but I want confirmation for my own sake. I was an IT professional… but 1000 ya :slight_smile:

If it’s the first time you plug it, I’d reboot the box…

Tnx a lot Herve5! After factory reset the web interface works!