[NextBox] .htaccess error on webpage

Right so everything is setup with the Quickstart so I have a *.nextbox.link.
Unfortunately this doesn’t allow local connections. At nextbox.local.
So I go to make my first backup. I put in the usb flash. It’s a real little one no external power required. It’s a 3.1 USB into the 3.0 Free slot.
It says can’t access .htaccess so disabling access or something to that effect.
I removed the flash drive. Ok so it doesn’t work with the flash drive.
P.S. The ssh public is refused by the server.
So no ssh.
Maps has no Unique column and, social is unable to be extracted in the tmp directory.
It still is telling me bad gateway. But, I can see the nextcloud page at the local ip, but, it’s not a trusted address. How do I regain access and, make a backup without getting locked out.

Says to install the nightly version, I can’t because, I don’t have ssh access
Reference The "unique" column option is not supported · Issue #541 · nextcloud/maps · GitHub

Same deal here no ssh access, and, Web OCC is not supported
Refence could not extract app social · Issue #1203 · nextcloud/social · GitHub

But, the new update did get the mail working, but, only the default mail not the rainlook or whatever because, it doesn’t support the https configuration

SIdenote I did get onedrive and google working with OpenID

Yes, this won’t work, proper HTTPS/TLS will never work for this URL as it’s not public, please see: Managing Remote Access — Nitrokey Documentation and/or Remote Access Walkthrough — Nitrokey Documentation for more about this topic.

Please don’t do this, we highly recommend to use an additional power supply (or powered usb hub), please see the hardware section here: Frequently Asked Questions — Nitrokey Documentation

Sorry, but I do not fully understand, “It” is who? Nextcloud? When? Disabling access to what? Please try to describe the procedure to reproduce the error you encountered, and use a powered usb-device.

Do you mean the ssh public key? Ok I’ll assume that, “refused by the server means”: inside the NextBox App, while adding the key? During your login attempt? Did you read and follow the ssh related FAQ here: Frequently Asked Questions — Nitrokey Documentation

We are using the stock Nextcloud Docker images, so if there are bugs within the apps which are related to Nextcloud in general we can only give limited support as fixing bugs which occur on apps within Nextcloud is out of our scope.

I assume with “it” you mean you access your Nextbox via the backwards proxy? If you get a bad-gateway accessing your NextBox via xxxx.nextbox.link please disable and enable the backwards proxy once and try again after ~30secs.

Sorry, this is hard to understand for me, the line before you wrote “I can see the nextcloud page at the local ip”, means you have access, right? So I assume you mean “secure access”? Please read the documentation for remote access: Managing Remote Access — Nitrokey Documentation

Finally, just you know: you can edit your posts here, so no need to make additions as separate post, also helps to keep things cleaner.

Best

NEXTCLOUD is running. The local ip address is not in the trusted domains in config.php so it won’t allow the connection. The gateway to nextbox.link is not active because, APACHE Webserver can’t access the .htaccess file and, disabled I guess whatever the quickstart script did because, I tried turning it off at the same time to make a backup with the flash. Would a crossover cable work to log in from 127.0.0.1 or localhost. I am not sure what is in the config.php for trusted domains in the standard docker image.

REFERENCE Nextcloud does not recognize trusted domain - 🚧 Installation - Nextcloud community

ALSO Adding the subnet to the whitelist did not work either

Well as far as the ssh public key I made one for the user on my box ‘live@debian’ then one for ‘nextuser@nextbox.local’ then one for ‘nextuser@*.nextbox.link’ then a complete new user so ‘nextuser@debian’ none of which gets accepted by the nextbox it says server refused also different kinds of keys ecdsa, rsa, and dsa still don’t work

Right because I turned on the quickstart script it won’t allow http connection and some of the software apps crash because, they don’t know how to redirect to the https page. So no unsecured nextbox.local access to the nextcloud. It’s still on the https I tried turning the quickstart script off at the same time as making a backup to the usb flash. But, I can’t access it via ssh to add the local ip address to the trusted domains in config.php so whatever is in the config.php trusted domains from the standard docker nextcloud image.

Reference Configuration Parameters — Nextcloud latest Administration Manual latest documentation

<?php $CONFIG = array ( 'instanceid' => 'oc8c0fd71e03', 'passwordsalt' => '515a13302a6b3950a9d0fdb970191a', 'trusted_domains' => array ( 0 => 'localhost', 1 => 'studio', 2 => '192.168.10.155' ), 'datadirectory' => '/var/www/nextcloud/data', 'dbtype' => 'mysql', 'version' => '7.0.2.1', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'oc_carla', 'dbpassword' => '67336bcdf7630dd80b2b81a413d07', 'installed' => true, );

These are roughly the contents of the trusted_domains inside the config, especially entry number one should always allow you to access your nextbox using the initially received IP during setup.

    0 => '<the first IP the NextBox received, during setup>',
    1 => '192.168.*.*',
    2 => '10.*.*.*',
    3 => '172.16.*.*',
    4 => '172.18.*.*',
    5 => 'nextbox.local',

Is your local ip range not within these? Did your NextBox receive another IP after setting it up?

Generally most of the behavior you describe is very uncommon, I would suggest to try a factory reset as described here: Factory Reset — Nitrokey Documentation … Maybe connecting a non-powered hard-drive did lead to data loss/corruption on the internal hard-drive.

No.

Sorry, but you really need to be a little more precise. Which whitelist? Where?

It is irrelevant with which user you create the ssh key, please do the following to test:

cd /tmp
ssh-keygen -f mykey
# press enter twice
cat mykey.pub
# copy the output to inside the NextBox App: "System Settings" -> "SSH Access Control"
# then you can login into your nextbox using:
ssh -i mykey nextuser@nextbox.local
# or instead of nextbox.local use your NextBox' local-ip

You should still be able to connect to your nextcloud using: http://nextbox.local and http://<your-nextbox-local-ip>, if this is not possible then something is wrong, please factory-reset (Factory Reset — Nitrokey Documentation) your device in this case. Further please note that activating the backwards proxy does not switch off regular http-access.

I see I cannot hold you back, but please don’t! Your local IP is already in there, if your local IP does not match with the trusted_domains something else is wrong, even if the catch-all IP-ranges don’t match your local IP, still the first line should match the IP the nextbox was using during setup.

Overall, I would clearly suggest to do a factory reset: Factory Reset — Nitrokey Documentation

best

Changing the local lan settings to the properly authorized subdomains is working.