Nitrokey 3 NFC finally works with Keepassxc 2.7.7 on Debian

using the “Yubikey”-option on in Keepassxc 2.7.7 it finally seems to work with my Nitrokey 3A NFC on stable Debian.
Don’t know if it worked for anybody earlier in this particular case?

It asks for the password as intended and needs the option “Hardwareschlüssel eingeben (Seriennummer XYZ)” checked.
What seems a little bit weird: If the Nitrokey is plugged in, the access is granted (without touching the key?!) when I remove the Nitrokey from USB it fails (as intended).

Is this working as intended?


yes, it worked with earlier releases for a Nitrokey too, but with 2.7.7 they improved the key detection, which was not super stable at the beginning. There are some threads in this forum how to create a backup key. You should do that prior to using it, because you’ll have trouble in case the 1 key gets lost/broken.

It’s normal you don’t have to touch the key, because the challenge-response secret does not support it. So, a password will be necessary as 2FA for most users.