Nitrokey 3A NFC IOS not working

Just got the nitrokey 3a, but it’s not working with my iphone 13 pro max.

Tried to setup a security key for discord as a test, but my device does not recognize the key at all.

I even looked up the exact location of the NFC chip on my phone and it still doesn’t work when I put it there.

Looking at the forum, it doesnt seem like I’m the only one thats having trouble using the key via NFC.

Is this just faulty hardware or software related? Any ideas on how to get it working?

Judging from the number of NFC complaints, it’s a widespread issue. It’s highly related to a phone one’s using. It seems that competition got this solved though (other security keys), so it’s a bummer Nitrokey is affected so severly.

Here are some things you can try to fix the issue:

  1. Hold the Nitrokey 3 NFC at the back of your iPhone near the NFC antenna for a few seconds on the home screen. It should appear as NFC Token with a default NFC link to “”. Does it show up?

  2. Can you register or authenticate on this website:

  3. Have you set up a PIN for your Nitrokey 3? You can follow the instructions here: Set PINs - Nitrokey Documentation

  4. When prompted to authenticate, did you select “Other” and choose to use your Nitrokey instead of FaceID?

  5. Did you enter your PIN while still connecting the Nitrokey wirelessly?

  6. Does it work when you connect the Nitrokey 3 via USB?

  7. Does it work via USB with Discord?

Although using NFC may not be the best experience, it does work for me on my iPhone 11 Pro Max. I have noticed that some providers or tenants may not allow non-certified FIDO2 devices, or registration may need to be done on a PC before authentication can work on the phone.

I also suspect that lacking a PIN or disconnects while entering a PIN might block the device and one does not get feedback why the login does not work.

I’d add that some phone cases are thick enough to seriously damp NFC signal. However this isn’t the problem for me with a competition’s key. With some phones I can’t use Nitrokey 3 NFC even without the case.

The fact that all these security keys get into locked state after a failed connection doesn’t help with troubleshooting. You need to move the phone away for a couple of seconds and back again.

BTW all iPhones I tested seem to have the NFC antenna somewhere near the top left corner or opposite from the camera. Some Samsungs with the fingerprint reader have it located on the back in that area. That helps a bit because cases usually have a cutout there to allow fingerprinting so singable isn’t dampened that much.