[Nitrokey 3A] 'nitropy test nk3' fails after fw update

Today I saw that there is a firmware update (1.0.2) available for Nitrokey 3A. (Github says it was released 28 days ago, but I doubt that. :slight_smile: )

I applied the update with nitropy which worked flawlessly. But nitropy nk3 test --pin XXX gives me a FIDO2 failure:

(<ERR.BAD_REQUEST: 2>, CtapError('CTAP error: 0x34 - PIN_AUTH_BLOCKED'))

Now I can’t add the key to, for example, gitea:

A logfile is available, but I don’t know if I can/should post it here?


This looks like the PIN’s attempt counter is used up. Can you reinsert the key and try again?
In general there are 8 attempts, but only 3 can be used per power-cycle. You should have another 3 attempts after reinsertion.

Thanks, that indeed solved the problem with nitropy test. But I still can’t add the key to my gitea-Account. That could perhaps also be a gitea problem, but the Nitrokey FIDO2 stick works there, though.

This might be connected with the FIDO U2F not working ideally yet. We are looking into it this week:

Perhaps FIDO2 would work for you. Which browser did you use? In case gitea does support FIDO2, it would work only through Chrome, unless you use Windows.

gitea supports WebAuthn (which means more or less FIDO2, right?). Actually I tried Firefox on Linux. But Vivaldi (Chromium based) behaves identically.