Nitrokey 3C stopped working


My Nitokey 3C suddenly stopped working. When I plug it in then the light does not flash. However, it is properly recognized by Linux:

 usb 1-1: New USB device found, idVendor=20a0, idProduct=42b2, bcdDevice= 1.02
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1: Product: Nitrokey 3
 usb 1-1: Manufacturer: Nitrokey
hid-generic 0003:20A0:42B2.0007: hiddev98,hidraw5: USB HID v1.11 Device [Nitrokey Nitrokey 3] on usb-0000:05:00.3-1/input1
cdc_acm 1-1:1.2: ttyACM0: USB ACM device
usb 1-1: USB disconnect, device number 7

It is my backup key and it has not been used frequently, but it worked correctly before.
nitropy does not recognize it anymore.

Any idea? Should I buy a new one to replace it?


It seems that when using the possibly broken key then it recognizes it and it is immediately disconnected (see above). I tested on multiple systems.
The key seems to be broken, I ordered a new one. However, if there is any idea on how to revive the possibly broken one then let me know.

nitropy does not recognize it so any reset etc. does not work. Can I reset it also directly on the hardware? (e.g. tipping it twice?).


It should be possible to switch to the bootloader mode (by shorting proper pads on the PCB), which would allow to update the firmware to the latest signed with nitropy. I do not know if that would fix the problem.
Let’s stay in touch for the further debugging. I will pass this post to the internal team to work further.

Thanks for the quick reply.
The key stopped working completely - not anymore recognized by the system. It is a bit strange, because it is the backup key that is rarely used (was latest firmware, worked after the latest firmware upgrade) and that was stored away in the plastic bag they were sent with. I would have expected it from the key that is for daily use… Both have been one of the first batch that were sent to customers of the Nitro 3C NFC.

Nevertheless, I ordered a new key. Now also the “time difference” between their creation is much larger, so I will also reduce probably the risk that both fail at the same time. I hope the new “backup” key arrives in time.

This looks like a hardware issue.
Please write to our support email address to ask to get this one replaced.

1 Like

Also the second key broke … Luckily I bought a replacement for the the first key that broke.
The second key was also from the first batch.

It seemed to have happened after trying to use it with NFC a lot.

This time though I still get some errors:

[ 3206.884809] usb 1-1: new full-speed USB device number 11 using xhci_hcd
[ 3211.920620] xhci_hcd 0000:05:00.3: Timeout while waiting for setup device command
[ 3217.300156] xhci_hcd 0000:05:00.3: Timeout while waiting for setup device command
[ 3217.508350] usb 1-1: device not accepting address 11, error -62
[ 3217.508526] usb usb1-port1: unable to enumerate USB device
[ 3251.235550] usb 1-1: new full-speed USB device number 12 using xhci_hcd
[ 3266.831147] usb 1-1: device descriptor read/64, error -110
[ 3271.427062] usb 1-1: new full-speed USB device number 13 using xhci_hcd

firmware is the 1.4.0