Nitrokey-app not working on Trisquel

I just installed the nitrokey-app on Trisquel, which is an Ubuntu based distro. But whenever try to start the nitrokey-app from my terminal, i see the following message: Application started successfully. And then nothing happens.

I installed the nitrokey-app from the repository, following these instructions: Ubuntu | Nitrokey

How can i solve this problem?


Application icon should show up in tray bar. What window manager do you use? Latest GNOME (which may be bundled with your distribution) removes the tray bar altogether.
Another cause might be lack of communication with window manager due to running from console.
Could you start the application from within graphical menu?

I’m using GNOME. I tried launching the application by clicking on the icon in the application menu, and tried it from console. Both didn’t work.

Do you know which version of GNOME do you use?
To confirm whether App is running or not you may use pgrep:

$ pgrep -a nitrokey-app 
7681 nitrokey-app

If there are no results then the App is not running.

Edit: we already have an open issue regarding GNOME and tray issues: #274. Please follow the updates there, if the app would appear to be running but without the tray.

I’m using GNOME 3. pgrep shows that nitrokey-app is running indeed, but i don’t see anything in the tray or anywhere else.

Is there another way of getting it to work? There haven’t been posted any solutions in the issue you posted.

As a workaround you can try with installing the topicons extension. Here is it’s Github home page.

Doesn’t work for me unfortunately.


besides installing the extension you have to enable it as well. Please start gnome-tweak-tool and enable it there. After that you may have to logout and login. This should work on every pure Gnome 3.26.

Kind regards

Thanks! It works now for Gnome. Is there any way to get it to work on other window managers too? Like DWM?

Well, it should work on every desktop environment which have a system tray :thinking: Only the newest Gnome version (3.26) is known to have this issue. This is a design decision by the Gnome Project. All conservative DE should work though.

Kind regards