Nitrokey bricked after failed update?

The Nitrokey 3C NFC was announced in 2021 and that’s when I bought it. I received it 1 year later in 2022 and have never used it since. Today I tried to use it for the first time. I installed the Nitrokey App 2 for Windows. I tried to update the Nitrokey but on finalization it stuck at 98%. After some time, I clicked on another menu and then went back to the firmware status and saw that the update had failed. I don’t know what I did wrong. Now I connect the device but it is no longer recognized. I think I bricked it after the failed firmware update. Is there anything I can do about it because it has been a terribly frustrating experience?

Hey @Nemuza,

fully understand your frustration - this should clearly not happen - the fact that the process didn’t finish in “finalization” could hint that the update went through but something failed, as finalization actually just means “wait for the device to re-appear” …

Could you please try the commandline tool nitropy and run nitropy.exe nk3 status and/or nitropy.exe nk3 test and tell us the output.


Hey @daringer,

Thank you for your help. The output is the same for both:

Command line tool to interact with Nitrokey devices 0.4.46
Critical error:
No connected Nitrokey 3 devices found

best regards

Hey @Nemuza

please write our support for further assistance, write to support (at) nitrokey (dot) com for further assistance. Please include your order number (SOxxxxxx)


UPDATE: after waiting for a few minutes nitrokey mentioned below works again and even reports successful update - nitropy didn’t brick it. There is an issue with the build of nitropy shipped on archlinux, because trying to run nitropy nk3 update from nitropy built with pip the update runs fine and finalizes correctly. I’ve reported it to the current maintainers.

I may have bricked my nitrokey 3A as well after unsuccessful firmware update - running Archlinux.

~ ❯ nitropy nk3 update                                                                                        22:08:03
Command line tool to interact with Nitrokey devices 0.4.46
Do you want to download the firmware version v1.6.0? [Y/n]: Y
Download v1.6.0: 100%|██████████████████████████████████████████████████████████████| 909k/909k [00:01<00:00, 484kB/s]
Current firmware version:  v1.5.0
Updated firmware version:  v1.6.0

Please do not remove the Nitrokey 3 or insert any other Nitrokey 3 devices during the update. Doing so may damage the Nitrokey 3.
Do you want to perform the firmware update now? [y/N]: y

Please press the touch button to reboot the device into bootloader mode ...

Perform firmware update: 100%|█████████████████████████████████████████████████████| 461k/461k [00:06<00:00, 73.9kB/s]
Critical error:
Failed to perform firmware update
        Exception encountered: AttributeError('desc')

Critical error occurred, exiting now
Unexpected? Is this a bug? Would you like to get support/help?
- You can report issues at:
- Writing an e-mail to is also possible
- Please attach the log: '/tmp/nitropy.log.5l1pzh59' with any support/help request!
- Please check if you have udev rules installed:

Any help? nitropy has been behaving really strange in the past few weeks/months

Hi @dan

I have contacted support. Unfortunately, the Nitrokey is out of warranty. I have been offered a 10% discount to order a new one.

Best regards