Nitrokey Fido2 stopped working after firmware update

My Nitrokeys Fido2 stopped working after I updated them to firmware 2.4 via the website. With the old firmware they worked. Is there a bugfix, or how can I restore the old firmware?

What excactly did you do? What operating system and browser are you using? Is it detected at all by nitropy? If so, could you try to update from there and also attach a logfile?

@szszszsz What details are required for further troubleshooting?

I tested it with OSX and Linux, Firefox & Safari. After the update I got communication and then NotAllowed errors when accessing websites (Gitlab/Github). Other keys (Nitro 3C) still work with these configurations.

nitroypy recognizes them properly, they seem to be ok.

The update with nitropy (–force) failed. Unfortuanetly I’m not allowed to attach the log file. Here is a screenshot

Repeating the update worked. Now the key is also working again.


1 Like

I also had the same problem. Rearranging the firmware and rebooting FIDO helped. But the command does not work:

nitropy fido2 status

log file: