Nitrokey HSM 2 not found on Windows over a RDP connection

Hi there,

currently i have some issues with my Nitrokey HSM 2.

First of all i want to mention that my Nitrokey HSM 2 works perfect with another computer.

On a Windows 10 x64 it isn’t working. I’m using the Windows 10.0.17763

Under the Device Manager it shows me a MicrosoftUsbccid Smartcard Reader (WUDF) and a Unknown Smart Card (don’t know if this is ok).

I’ve installed OpenSC 0.20.0, the win64 and win32 installer as administrator.

When I try to find the smartcard with “certutil.exe -scinfo” it shows me:
The Microsoft Smart Card Resource Manager is not running.
SCardAccessStartedEvent: Service is in an unknown state.
CertUtil: -SCInfo command FAILED: 0x80070006 (WIN32: 6 ERROR_INVALID_HANDLE)
CertUtil: The handle is invalid.

The services “Smart Card” and “Smart Card Enumeration Service” are running.

I also tried to install only one OpenSC type (win32 or win64), but it failed everytime with the exact same error.

Please let me know if you need additional information.

Thanks in advance!

Edit: A former collegue of mine gave me a very useful hint. This problem occurs because I access the Windows machine via RDP. This problem was discussed before here in this forum:

Therefore its not a Nitrokey issue, so i would say this ticket can be closed.