Nitrokey Passkey is not recognized on any OS

To put it simply, the device does not seem to respond to touch or change LED lights in response to a browser/app. The lights are sometimes constant yellow(ish) or red, or blue for 1 second. I can describe this in more detail if you want.

Anyway, here’s what I’ve tried so far with no luck:

  • Everything on FIDO2 With Linux - Nitrokey Documentation
  • Fedora Kinoite 40, Ubuntu 24.04, Windows 10 (22H2), Android 14, Fedora Workstation 40 (on live cd)
  • Flatpak and non-flatpak versions of latest Firefox and Chromium-based browsers, on webauthn io, passkeys io and Github
  • KeePassXC’s passkey support

Both lsusb and lspci didn’t output any nitrokey entries.
Nitropy commands “nitropy fido2 status” and “nitropy nkpk status” resulted in errors. The logs from these commands showed something along the lines of “Permission denied: '/dev/hidraw” (hidraw0, hidraw1, hidraw2, etc.).

Can someone tell me how the Nitrokey Passkey is supposed to work, step by step? And should it be plug-and-play and no configuration?

1 Like

It should work out of the box when the Nitrokey gets detected and the udev rules in place on Linux and for Windows you just need a browser wirh FIDO2 support. Looks like your key is broken.

1 Like

If you plug the key in, are there any notes / messages in dmesg on your linux? Those could give a hint on whether the key is more or less broken.

Nothing at all is added to dmesg when I connect the passkey. I tested with a flashdrive just to make sure the port isn’t busted, and dmesg does add some entries for that one, so it is not the port that is broken.

Speaking of broken, as I was pulling the passkey out of the port (granted, my PC case has a really stiff USB ports on the front), the metal part for the o-ring that is also supposed to be for touch, broke in the middle.

If nothing happens on dmesg (as you tested, it works for other things), I would highly suggest to contact support directly and try the RMA process (or whatever it’s called).

P.S.: Maybe let us on the forum know how it worked out.

My RMA request has been resolved very quickly and I was sent a new passkey.

Today it has arrived and I can confirm that this one works without any issues!