Nitrokey Start: can not change PINs

Hi, I am trying to setup a new Nitrokey Start with the instructions from https://www.nitrokey.com/documentation/installation#p:nitrokey-start&os:linux

Everything seems to work fine (personalising, generating/uploading keys) up to the point when I am trying to change the PINs. Setting any new PIN (for both admin and user) gives a message: “Error changing the PIN: Conditions of use not satisfied”

I have tried different characters/combinations (only digits, mixed digits/letters, all 8+), factory-reset the device, tried with different GnuPG versions and on different machines, with both RSA and ECC keys.

Any ideas?

Firmware version: FSIJ-1.2.15
gpg (GnuPG) 2.2.20
libgcrypt 1.8.5
OS: Gentoo Linux

Hi @alexkn!

I am sorry, it seems that the start page was not updated yet.

  1. New PIN has to be over 14 characters for both Admin and User since the latest firmware - this is the only requirement. Please make sure though it does not consist only from digits for safety.
  2. Initially only Admin PIN can be changed. User PIN cannot be without keys present (either imported or generated).

Details: https://github.com/Nitrokey/nitrokey-start-firmware/releases/tag/RTM.8

1 Like

@szszszsz thanks for your answer, that was the case indeed! Was just 2 characters short :smiley: