Nitrokey Start isn't recognised on Mac OS 10.14 nor 10.15

Hello everybody,

I received my Nitrokey Start device today morning and since then, I’m not able to use it. I followed the instruction in the official documentation (link), but the system simply doesn’t recognise the key. I tried on 2 Mac OS devices, one of them running version 10.14, the other 10.15, none of them worked.
I installed gnupg and gnupg2 as well, hoping one of them may see the NKS:
gpg --version
gpg (GnuPG) 2.2.17
libgcrypt 1.8.5

The gpg --card-status reports the following:
gpg: selecting openpgp failed: Operation not supported by device
gpg: OpenPGP card not available: Operation not supported by device
I read here, among the topics (link) that I should compiled and install pcsc-tools (current version 1.5.4), but the compile process failed.
What else should or can I do?


Actually only GnuPG 2.x should be installed. Depending on how is this packaged, it might make a conflict in device access between these two.

Could you connect the device and attach please the result of system_profiler SPUSBDataType? This should list all connected devices in the OS.


On the one I have in my hand right now only GnuPG 2 is installed.
The output of that command is:

system_profiler SPUSBDataType
2019-10-29 21:26:53.746 system_profiler[91495:735167] SPUSBDevice: IOCreatePlugInInterfaceForService failed 0xe00002be

USB 3.0 Bus:

  Host Controller Driver: AppleUSBXHCILPTH
  PCI Device ID: 0x8c31
  PCI Revision ID: 0x0005
  PCI Vendor ID: 0x8086

    Internal Memory Card Reader:

      Product ID: 0x8406
      Vendor ID: 0x05ac (Apple Inc.)
      Version: 8.20
      Serial Number: 000000000820
      Speed: Up to 5 Gb/s
      Manufacturer: Apple
      Location ID: 0x14700000 / 17
      Current Available (mA): 900
      Current Required (mA): 896
      Extra Operating Current (mA): 0
      Built-In: Yes

    Apple Internal Keyboard / Trackpad:

      Product ID: 0x0274
      Vendor ID: 0x05ac (Apple Inc.)
      Version: 6.24
      Serial Number: D*******************
      Speed: Up to 12 Mb/s
      Manufacturer: Apple Inc.
      Location ID: 0x14400000 / 3
      Current Available (mA): 500
      Current Required (mA): 500
      Extra Operating Current (mA): 0
      Built-In: Yes

    Bluetooth USB Host Controller:

      Product ID: 0x8290
      Vendor ID: 0x05ac (Apple Inc.)
      Version: 1.68
      Manufacturer: Broadcom Corp.
      Location ID: 0x14300000

Try ioreg | grep Nitrokey in the terminal while the Nitrokey is plugged in. If you don’t see a text, the Nitrokey is not recognized by macOS. You don’t need any driver for this as teh USB subsystem will use a generic USB driver.

1 Like

Thank you for the suggestion. It seems the Mac (10.15) really doesn’t recognise the key. I successfully compiled and installed the pcsc-tool, running the pcsc_scan diesn’t show the Nitrokey while it’s plugged in, plus the ioreg also cannot find it:

Plug’n play reader name not supported. Using polling every 1000 ms.
Scanning present readers…
Waiting for the first reader…
peter@localhost:~/Downloads/pcsc-tools-1.5.4$ ioreg | grep Nitrokey
peter@localhost:~/Downloads/pcsc-tools-1.5.4$ ioreg | grep -i Nitrokey

I got on a Windows 10 laptop, plugged in the Nitrokey and that machine also didn’t recognise the device. Nothing at all. No notification that something unknown is connected or a driver is missing.
Can be the device has a defect?

It looks so unfortunately. We do tests of each device after the production, but such devices are occurring from time to time.
Please contact (linking to this page) for further information.

Before that, a last chance test - I will run the same commands on my side to confirm, how the output should look like with the device inserted.

Confirmed these should list your Nitrokey Start (macOS 10.13.6):

$ system_profiler SPUSBDataType | grep Nitrokey
            Nitrokey Start:
              Manufacturer: Nitrokey

$ ioreg | grep -i Nitrokey
    | |   |       |   +-o Nitrokey Start@fd130000  <class IOUSBHostDevice, id 0x1000005a9, registered, matched, active, busy 0 (8 ms), retain 24>
      | | | +-o Nitrokey Start@fd130000  <class AppleUSBDevice, id 0x1000005ab, registered, matched, active, busy 0 (61 ms), retain 17>

AFAIK on Windows 10 there should be some notifications about connected device as well.

Thank you for the test and confirming my issue.
I sent an e-mail to jay@ and to info@ during the weekend, I’m waiting for response at the moment.