Nitropad Firmware Update left some functions not working

Hi there,
i performed an update for the firmware of my Nitropad.
To me it seems like its working fine. Except it somehow “forgot it’s a Nitropad”.

The HOTP states: N/A so it seems like it’s not checking for a Nitrokey. Normaly this is the spot where you find if the check was succesfuly or not.
Also the Thinkpad T430 should be named NitropadT430 at the top of the menu if i remember correctly.
Here is a picture:

But i dont know how to fix this. I reseted everything and even reinstalled the firmware, but its still not working, so i’m out of ideas and hope to find help here :slight_smile: Please tell me if further information is needed here.
Nitrokey and Laptop are generealy working fine. I’m sure it’s a software issue or i configured something wrong.

For the update process i followed this: Firmware Update — Nitrokey Documentation

Thanks for all the help i can get and kind regards!

Ok, i found some things:
In the heads documentation ( is written, that currently only the x230 is able to handle hotp verification through heads. So it makes sense, that the hotp verfication is not working on my device after i installed another rom.
This also makes sense, because the rom for the x230 is has the hotp_verrfication in its name, but not the rom for the t430.
But it worked when the device was sent to me. So i’m wondering why the official newest firmware isn’t supporting this feature or where the version i had initially could be found.