NitroPad X230: Booting media in BIOS

Hallo, I bought a NitroPad X230 and I was trying to install Windows on a partition of the device.
I used a 8 GB USB Flash Drive which I create with the Windows media creation tool on a Windows computer. Then I tried to boot the device selected the first entry and got an error where no boot able device was found (see picture). First I thought that the media creation tool did something wrong, so I downloaded the latest Windows iso file and created the boot drive with Rufus and balenaEtcher, without any result.

Afterwards I tried to boot an Ultimate Boot CD flash drive which usually always works. There appear a lot of boot options and when I select one it creates a boot loop…

Do you know why it is not working? When I create a boot drive with Linux Mint or Ubuntu I do not have any problems.

I am sorry for the delay.

I am afraid MS Windows 10 is not supported. Perhaps older releases (Windows 8, Windows 7), but I cannot find any documentation regarding this right now. Moreover supporting Windows OS is not our target with this product, so this rather not change in the long run.

Too bad. I thought multi boot with MS is supported in coreboot.
But one question is still open. Do you why my Ultimate Boot CD does not boot?

Unfortunately I do not know the cause. I do not see any mentions about Windows or UBCD in the tickets in the Heads project either: