Nitropad X230. Keyboard does not answer

For first use, as i try to write the password to unlock for the first time (“please unlock disk sda5_crypt”), the letters do not appear when i type the keys.
I don’t know why and so i can’t write the password.
Though “enter” key works.

If anybody…

This might by design, as it is common to not show the count of the password characters to the adversary.
Can you try to enter the password regardless?

Hi. Thank you.
Yes i have tried and the answer is
“cryptsetup failed, bad password or options ?”

You tried the Initial password “PleaseChangeMe”? What OS do you using (my guess is Ubuntu). Maybe if this is a keyboard issue you could try an external usb keyboard.

Yes i tried this password. I use Debian.
I also tried with an usb keyboard and the same happens : when i use a type for a letter, nothing happens.
But when i type “enter” or “ctrl+alt+suppr” the keyboard answers. The same happens with the usb keyboard.
Thank you for your help

Is it usefull if i tell you that the page where i’m asked to write the passphrase looks like a terminal ?

that actually expected that it looks like that. If the Initial Password is not working maybe contact

Thank for your help. I will first wait for the help of time.
When the answer comes i let you know