NK Storage and macOS - how do I upgrade Firmware

Looks like for the Upgrade of a Firmware I need to use a Windows System or need to compile it on my system.
Do you have any other more user friendly option ?

You would need dfu-programmer. For macOS perhaps the easiest would be to
install it via Homebrew or MacPorts.

Hmm, ok - I will rather try to use it with Parallels and Windows7 as this will not pollute my Host system. :grinning:

But I would prefer a more user-friendly firmware update possibility through the stick itself.

Today I was able to do the Firmware Upgrade. I tried to do it in a virtual machine from Parallels. Here are some experiences :

  • Windows 7:
  • Debian 8 /Jessie
  • I was not able to get Nitrokey-app installed , I also had difficulties to get dfu-programmer recognizing the key. But that could be all my faults.
  • Ubuntu 16.04
  • That worked following step-by-step the instructions

So I am very happy now and have a all prepared VM to update the Firmware every time I need

Could you elaborate, why Nitrokey App doesn’t work on Debian 8? What went wrong? Any error messages?

1 Like

Hey Jan,

I did it again from scratch - new VM, and all the installations etc. The difficulty was the installation of nitro-app out of the old repository - but it worked with editing of /etc/apt/sources.list . BTW: The App is still 0.6.3 correct ?

After that , the build , install and run of dfu-programmer was no further problem. This time also my admin pin was still working after the flashing.

I still think on a Mac using a VM with Ubuntu might be the fastest way to do the firmware upgrade (Gnome 3 Desktop is a bit strange for a first time user as the Nitro-App is not visible by default ). Now at least I have with Debian an also working Alternative :smiley:

I’m glad it worked.

I guess Debian’s repository doesn’t contain the most recent version yet.