NK3 USB-C NFC not working

Hi there, got my NK today, but it does not work, nitropy nor firefox (update.nitrokey.com) are recognizing the key. installed the udev rules, rebooted my notebook (latest manjaro linux and second notebook with linux mint). lsusb is not showing anything. When i put the key to my android phone nfc reader, it only opens up nitrokey.com page. Any hints on how i can “reset” or start the NK3?
There is also no LED lighning or blinking.

Thanks!

I think with NFC only limited operation is possible, in part due to limitations of the OS, in other part due to the protocols you get with NFC and in other part due to the power of NFC.

  1. neither linux itself nor the browsers in linux natively support FIDO operations in Browser
  2. update.nitrokey.com doesnt work with the NK3 in the first place.
  3. nitropy apparently seems to work at least in part using libusb, likely you wont get mich NFC stuff over that.
  4. I’d assume you dont really have much power left to draw the LEDs
  5. that the phone opens the nitrokey homepage likely is due to an NDEF or whatever it was called. solo2 people experience similar things (and the nk3 is based on the solo2 as far as I am aware)
  6. the proper way to use the NK3 on your phone with NFC would be to first start a FIDO request and tell your phone to use an NFC key, and THEN tap the NK3.
    you might have it react twice and both do the request AND open the nitrokey website tho, at least that’s what I suspect due to solo2 experiences of users.

my primary goal is to use the nk3 via usbc on my laptop, and this is how i primarily were testing it. so consider my question regarding usbc primarily… not nfc. usbc should give enough power in my opinion?

i also have a solokey, there google login works, even pam u2f works on linux. Since the SoloKey and some Nitrokeys sharing some codes (web updater, nitropy…) i assume this is not the primary issue.

oh okay, sorry, considering the title I thought you were meaning that you have issues using it with NFC in particular.
sure USB should not have an issue regarding power.

regarding solo to nitrokey comparison you need to not forget that there are 2 generations of solo and therefore also 2 seperate nitrokey versions based on those.
the first generation solo (solo, solo tap, somu) with the nitrokey FIDO2
the solo2 and the nitrokey 3.

between the generations the firmware is vastly different and therefore the web updater which is made for the nitrokey fido2 shouldnt work with the nitrokey3. (the website even states nitrokey fido2 only)

also you say you have a solo, is it an original solo, or a solo2?

also while it’s generally not a good idea to do it does nitropy list show anything interesting when run as root, or dmesg when you plug the nitrokey in?

generally speaking maybe there’s an issue with the usb plug on your nitrokey as the ndef response with the nitrokey shows that the nitrokey likely isnt 100% dead.

no dmesg message when connecting to usbc, tried on both laptops, an asus and an lenovo one. nitropy or nitropy nk3 list does not show any device. i can see in nitropy logs, its trying to find /dev/hid*something … but it does not find anything. i rather think that thing is somehow bricked… i have not updated firmware, i was not able to even try that.
i’ve also tried nitropy with root, just to be sure it isnt a rights thing, but yes i know in general i should not need root.

As i said at the beginning, there is not even a led blinking or lightning when putting the NK3 in. This seems quite suspicious to me, or is the LED in NK3 missing?

I honestly have no idea whether the NK3 specifically has an Idea, most if not all others have so it could be assumed but I tried to not assume anything. if there’s no dmesg or other things it appears in it’s likely also not in bootloader mode.

that is not great it might be bricked or the USB plug not properly connecting to the board or whatever

Hi @Sebastian_Oad !

This looks like a hardware issue. Please write to shop@nitrokey.com linking to this page, and asking for the replacement.

  1. The LED should be flashing since the insertion to the USB port. If it is not, then the power apparently is not reaching the internals.
  2. The NFC test you run suggest the components are working correctly.
  3. I see you have already tried multiple PCs to make it work.
  4. The comparison with Solo 2 is right - it should behave similarly (but not exactly the same).

This looks like some problem with the USB plug. We test each Nitrokey 3 after production, but even so the damage can happen in transport.

@My1 Thank you for suggesting debugging steps!

1 Like

@szszszsz thanks very much, they opened a RMA quickly and i can send back the stick, now im waiting for a new one.
@My1 thanks also for helping me out debugging that problem!

Thanks and have a nice day!

1 Like

absolute no problem