PayPal and 2FA Security Key


I’m trying to set my new Nitrokey 3C NFC as a 2FA security key in my PayPal account. It always shows the message that something went wrong (Please try later …).

The same problem for my account on …

There is no problem on other websites.

Firmware of the key is v1.4.0. Pin is set. I tried it with Firefox, Edge and Opera. OS is Windows 11.

Does anyone got a solution?


Pin Requires that the Browser has fido2 support and not just u2f. I don’t know about Edge and Opera but Firefox has to be activated it:

Hello Chris,

I’ve checked it out. The option security.webauthn.ctap2 is already set to true in Firefox (v114.0).

I’m able to enter the pin of the nitrokey on the PayPal website. The error message only occurs after entering the pin and touching the key.

As I said, there is no problem on other websites (except PayPal and with Firefox and Nitrokey with pin. All Firefox addons are disabled.

I set up the key in PayPal via chrome. After that, I can log into PayPal with the key.

I also tried it via chrome, same problem…

Here is a screenshot of the error message (in german):

“Unfortunately, a problem has occurred. Please try again.” (translated)

I’ve the same troubles (Errors) with paypal, Firfox and Chrome, but using ubuntu 20.04.

Still issue like described above with PayPal. I can’t register the key. Different OS and Browsers.