Problem booting Qubes 4.1, system hangs up after entering LUKS password

Hi there,

I have a Nitropad X230. I am a novice when it comes to Linux distros, have been using Qubes for close to half a year now. Most of the time I was able to fix my problems looking into the documentation and/or reading through forum entries. This time I can’t figure it our for myself, so any help is appreciated.

Over the weekend, I have updated to Qubes 4.1. The installation itself worked. I was able to log in to Qubes 4.1, everything looked fine, I didn’t run into any issues. I restored my Qubes backup and adjusted some settings (in the AppVMs, not in dom0), just to check if I’d run into problems. I didn’t. I then powered down.

Now, when I start to boot, heads is behaving as expected. I have three options
1.) Qubes,_with_Xen_hypervisor_[/xen-4.14.5.gz]
2.) Qubes,_with_Xen_4.14.5_and_Linux_5.15.52-1.fc32.qubes.x86_64
3.) Qubes,_with_Xen_4.14.5.config_and_Linux_5.15.52-1.fc32.qubes.x86_64

Option 1.) and 2.) bring up the screen for me to enter my password. After I do that, nothing seems to happen. I’ve waited for up to 10 minutes, no change. EDIT: If I type in the wrong password, it prompts me to try again. If I type in the correct password, the progress bar is loading and then nothing happens. END EDIT
Option 3.) fails completely with this message in the console

!!! Failed to boot w/options: Qubes,_with_Xen_4.14.5.config_and_Linux_5.15.52-
1.fc32.qubes.x86_64 [xen|kernel /xen-4.14.5.config 
placeholder console=none some other info I can post if it is relevant
!!!!!! Failed default boot
New value of PCR[4]: a hash
!!!!!! Starting recovery shell

Here are the files I currently have in /boot/efi/EFI/qubes
xen-4.14.5.efi xen.efi

Don’t know what to do.

Thanks for helping me.

These are the last lines after entering the password

Starting Qubes DG agent...
[   OK   ] Started Qubes input proxy sender (keyboard)
[   OK   ] Started Qubes input proxy sender (keyboard)
[   OK   ] Started Qubes input proxy sender (keyboard)
[   OK   ] Started Qubes input proxy sender (keyboard)
[   OK   ] Started Qubes input proxy sender (mouse)
Starting Qubes memory management daemon...
Starting Qubes OS daemon...
Starting Home Area Manager…
Starting Login Service
Starting Daemon for power management…
Starting The Xen xenstore…
[   OK   ] Started Qubes DB agent
[   OK   ] Started Home Area Manager…
[   OK   ] Started Login Service
[   OK   ] Started Daemon for power management…
[   OK   ] Started The Xen xenstore…
Starting virtualization daemon…
Starting xen-init-dom0
Starting Xenconsoled
[   OK   ] Started Xenconsoled
[   OK   ] Finishedxen-init-dom0
[   OK   ] Started virtualization daemon
[   OK   ] Started Qubes memory management daemon
[   OK   ] Started Daemon for power management
[   OK   ] Started Qubes OS daemon
Starting Qubes Domß startup setup…
[   OK   ] Started Qubes remote exec policy daemon
[   OK   ] Finished Qubes Dom0 startup setup
[   OK   ] Started Qubes memory information reporter
Starting Start Qubes vm sys-firewall
Starting Start Qubes vm sys-net
Starting Start Qubes vm sys-usb
Starting Start Qubes vm sys-whonix
Starting Permit User Sessions
[   OK   ] Finished Permit User Sessions
[   OK   ]  Started Command Scheduler.
Starting Light Display Manager
Starting Hold until boot process finishes up…


thats sound a bit like a qubes problem, to me since it worked before the backup restore.
Not shure what this could have caused if you say you don’t touch dom0. Maybe to many auto start qubes? just a wild guess. Maybe is a good place to get help

I re-installed everything. Now it is working. Don’t want to start guessing so I’m just posting this to say I managed to solve this problem by some other way. Thanks for your answer, @nesti-nitrokey!

1 Like