Qubes 4.2 install iso

I would like to install Qubes 4.2 on a Nitropad NS70.
I couldn’t find any OEM install .iso in your ftp that has a recent version 4.2 install.
The only one available seems quite old (more than a year) and is still dom0 Fedora 32.
It seems to be a real hassle to use this old 4.1.2 version and then moving to 4.2. It does not even seem possible to do it on a NS70 due to problems with cryptsetup/initram or dracut different scheme for unlocking the LUKS container.
Should we then rather use the official QubesOS 4.2.1 iso? Would this work on this hardware? What exactly would be the differences between a generic 4.2.1 install CD from Qubes and an OEM version distributed by you and Qubes Certified on the hardware ( or is it even certified at all for this machine?)
Thanks for advise.
Make it simple to do, pls

The one linked via https://docs.nitrokey.com/nitropad/qubes/os-reinstallation appear to be R4.2.0 only.
Which ftp do you refer to?

I got it from:
Index of /files/ci/nitropad/qubes-oem
Sorry, I didn’t use (or missed) the link you mention above for os-reinstallation, specifically for Qubes, which indeed has an R4.2 OEM iso there. Very fine, then!
In the meantime, I had tried to install the official 4.2.1 iso from QubesOS repo and really this was a breeze. No problem at all during installation and afterwards everything works just fine (except for some function keys, but that was to be expected because it usually is the case) Anyway, all hardware is recognized and functional.
I may try to install from your OEM iso, just to see what the differences are.
Out of curiosity, what would those differences be between your OEM iso and the official stable release from QubesOS? Is it just a question of certification? Or hardware coverage?
Can I use one or the other indifferently on this laptop?

Good you can confirm the default 4.2.1 iso from QubesOS worked fine for you. I think one main benefit from the Nitrokey iso image is for distribution, i.e. it is setup with the bundled Nitrokey when you receive it.

I remember Nitrokey once said a difference between their iso and the QubesOS upstream is they pre-install the Nitrokey-App. However, this reply was prior to the release of the NV line of Nitropads, which may benefit from/need extra suspend quirks (I read). I’m also sure Nitrokey spends time checking said usb-key functionality works as excepted prior to releasing a new QubesOS release for their hardware. The default QubesOS image can be installed on any x86_64 hardware and is not specifically geared for ‘certified hardware’ after all.

That’s what I know, it would be good to get a comment from Nitrokey to be aware of pitfalls, yes.

I fully understand this, it makes sense.

Yes, this is the case. The Nitrokey-App is not installed by default with the QubesOS upstream release; but it is easily available for installation into templates Fedora and Debian from their official repos. But I am talking here about the App 1 for the “before NitroKey 3” products, which can handle all previous Nitrokey cryptoki USB devices. Unfortunately, it is an all different matter for Nitrokey 3 products that will only work with the Nitrokey-App 2, which is not directly available unless one meddles with source.lists to add Nitrokey repos or download the .rpm or .deb packages from Nitrokey downloads, to be then installed locally via cli.

Yes, it would clarify the situation and obvious reasons (or not) for using the OEM iso rather than the QubesOS official release with post-installation of what is needed to make the Nitrokey USB devices work (be they first, second or third generation products)