Qubes OS installation NV41

Hello

On my NitroPC and NitroPad NV41 with preinstalled QubesOS I tried unsuccessfully to reinstall Qubes OS .

The first installation went half through : received an error at the end saying something went wrong, but the main system together with WhoniX have been installed. I’ve read on the forum that this means the virtualization have not been made at a hardware level and tried to reinstall agaion. Now I get the same error, but without installing anything else besides dom0.

Updated firmware successfully with the latest release , reset to factory NitroKey3, etc….still same error and no install. I thought the ISO might be corrupted , downloaded a new one on a new USB. Still the same…

I don t know what to do anymore.

Please advice
Thank You

This reads like the errors come up in the Qubes installation wizard?
It may indeed be an corrupted USB write. How do you create the USB (what tool or command do you use)?

Hello

This error indeed came up in the Qubes installation wizard . Towards the end of the installation ,after the first reboot it doesn’t even show all the system templates , Whonix and so on to toggle off/on when it was supposed to, during installation and instead I only get dom0.

I tried again today installing Qubes-R4.1.2-nitropad-oem-x86_64-en.iso downloaded from https://www.nitrokey.com/files/ci/nitropad/qubes-oem/ on a windows pc with Rufus in DD image mode.
Bought two new USB’s and tried with no success several times to reinstall Qubes on my nitropad.

It gets stuck to Starting new kernel…

Please advise
Thanks

I have not used Rufus, but that tool should get the USB copy right. dd itself has had some changes, so you need extra flags, if using it manually. In doubt, the correct manual use is in the Qubes guide: Installation guide | Qubes OS
The guide also shows Qubes’ warnings in case of virtualization limits via bios. If you did not get that warning during installation, I actually don’t know what may be the issue.

I have read Nitrokey staff stating in this forum the notable difference of their Qubes image is that the Nitrokey app is pre-installed. Hence, you should be able to directly boot the original Qubes R4.1.2 image to see if it makes a difference.
Not having done it myself, perhaps another Qubes user chimes in with an idea. If not, you better open a support ticket with Nitrokey. There have been a number of issues with their recent heads firmware images and if you’re using the latest one, one can’t rule that out.