Reset button stuck

I got the following issue : while I was away, my Nextbox got stuck in “Reset position”, with the blue LED constantly on.

I tried press the button in every way possible, but with no effect. The blue LED is always on.


Hey @thomas11072 ,

that’s very special, we are talking about a mechanical button, these usually tend to not press themselves :wink:

What I would like to say is that this is maybe not the result of the button being pressed, but moreover maybe a software issue (bug?). The fact that the blue LED does not change to red (factory-reset ongoing) is also an indication for that (because that would be the behavior, if the button is actually pressed for more than 5seconds).

Did you “feel” and/or hear the “click” of the button while trying to press it? There should be a recognizable haptic feedback from the button while pressing it.

Did you try rebooting your NextBox? In the NextBox App inside Nextcloud, there is the “System Settings” page, there is a “Reboot”.


Hey. Thanks for the reply.

I lost all connection to my Nextbox during my holidays away, I came home like a month later to see the blue light. So I can’t access or reboot anything (I lost local access too).

The button works as far as I know, I have the click and everything, but pressing it don’t change the blue color.

So maybe it’s a software problem, but I don’t really know how to solve it then.

Thanks again :).

Did you try to do a power cycle, so just disconnect the power and connect it again, does this change anything?

Nope it doesn’t change anything.

I checked and the Raspberry Pi seem to start up fine, but I can’t connect it to a screen, even with another microSD card (maybe it’s normal, I do not know).

I will try to check if I see the device on my network when I plug it in.
Thanks againx2

If you have opened the NextBox, make sure all wiring is correct, especially for the harddisk.
Btw. is the LED bright blue? or better, does the color change in any way after powering it on?

To have a screen working you have to make sure it’s connected before you power on the NextBox, sadly not all screens work with the raspberry due to some power limitations of the hdmi-ports.

All wiring seem fine as far as I know. And the LED is blue all the time, no matter what.

Sadly I checked the MAC adresses on my Network and the Nextbox does not appear anywhere. So I don’t know what to do next.

Quick update.
I manage to find a screen that works with the Raspberry.

I think the issue comes from the microSD card. With the original one I am stuck in boot, but with one I created myself it starts fine (I remove all components beside the original Raspberry).

So I am wondering now, if I can install back the Nitrokey Nextbox software back on a Raspberry Pi Os or else. Is nextbox-debian enough?

Thanks more and more :slight_smile:

Hey @thomas11072 ,

for the sd-card you can flash the image here: (use balena-etcher please for a verified flash), then you should have a working NextBox again.

Is this image available for people that don’t have a nextbox to test and use it, and contribute to the project improving the usability to everyone?

This image is free to use for anyone, you can also build it by yourself using our repository:

1 Like

Hi, it seems I have the same problem but for an new, unopened netbox.
I plugged it in, and then it was running for more then an hour but always switching between Yellow blink and Green fast blink. Then I plugged power out again and int again. Still same problem after plugin.
So I tried to factory reset, and it showed shortly red color.
But it did not boot afterwards and now it’s stuck in light blue/white, even after power unplugged for a while. Pressing reset button, feeling the click, short or longer then 5 secs has no effect.
Red led inside the box is on and Ping works but access via browser not.

What do you suggest to try next?
Before opening and loosing support and trying flash the image again on the sd-card.

Thx a lot for your help. @daringer

Hey @msnitro,

the light blue/white (LED Colors and Patterns — Nitrokey Documentation) LED means that the your NextBox is stuck in very early boot :confused: Please write to and include your SOxxxxxx, if you’re willing to reflash your sd-card we can arrange that your overall warranty still holds…


Okay, thanks for the super fast response. :pray: