Resetting Nitrokey Storage on Windows

Hi there,

I would like to reset my Nitrokey Storage without the Admin PIN on Windows 7. Since I still know the User PIN, I do not fear data loss.
Things I already tried include the guide given in the doc-section:

  • gnupg gives an error (ERR 100663404 Kartenfehler )
  • CryptoStickReset won’t work (SCardEstablishContext() failed (Ret=8010001D))

In addition, I tried to flash new firmware using the given guide, but dfu-programmer states there is “no device present”. I already installed three drivers (interfaces 0-2) using libusb, but this does not fix the problem. Instead, the Nitrokey was not recognized anymore and I had to remove the new drivers again.

I hope there is a way to reset. My Nitrokey Storage has been very helpful :slight_smile:

Thanks in advance!

[Feel free to answer in English or German]

Updating the firmware doesn’t reset the PINs. For resetting the PINs you should follow this guide. Did you try option 3? Is the device still recognized by the Nitrokey App?

Hi Jan,
thank you very much for your quick response!
Regarding the firmware, this totally makes sense. Thanks for pointing this out.

Yes, I tried option 3 and it says “ERR 100663404 Kartenfehler”. I should have mentioned that above more clearly. Sorry for that.
The combination Windows & no Admin PIN leaves two options (2,3) which do not work for me (see first post for error messages).

The device is still recognized by the Nitrokey App - which worked fine regarding my regular encryption purpose by the way - unless I install the drivers generated by libusb. Then it does not work anymore. Otherwise, and that is the way it is at the moment, I am able to use the Nitrokey App and even decrypt the storage using the known User PIN. So this works fine!
But unfortunately I am not able to reset the Admin PIN to default. Is there another option left?

Best regards

Please exit the Nitrokey App before trying to reset your device. That may solve the Kartenfehler issue.

Also you might try GPG4Win beta which includes GnuPG 2.1 and use option 5 from the referred instructions.

@Zahlenfetischist is this issue solved?

Hi Jan,
thank you for your answers.

Indeed this issue is solved. The solution was simply: exit the Nitrokey App before trying to reset the device.

Best regards