Shutdown complete or not, and more weirdness

I did a shutdown via web/nextbox app. Pulled the power after two minutes or so, the blue, dimmed out led still there…was this too early? It took three attempts afterwards, to properly boot it and get to the green led.

Now, the LED is green, but I get the “You don’t have permission to access this resource.Server unable to read htaccess file, denying access to be safe” error, probably because I tried to plug in a external powered usb disk, that still wanted usb power? Anyway, LED still green, error remains, with usb disk disconnected?

Offtopic: Could I use a LUKS encrypted disk for my backups? I thought I would just try, but now I’m here…

thanks for helping me.

The power-off of the raspberry pi does not fully power-off, but just halts the system so it’s perfectly fine to pull the power …

It’s weird that it took you 3 attempts, this and the htaccess issue both indicate that the internal harddisk does not get enough power or is maybe even damaged, did you disconnect all devices (despite the internal hard-drive of course) from the nextbox before powering up ?

Nope, right now LUKS is not supported

I did another “pull the power”; now all is fine. Where can I find out more, for example about hard disk health?

The external hard disk was only connected after the LED was green…should the htaccess error disappear after unconnecting the Harddisk?

external’s disk power supply is ok (disk shows up in nextbox app), now I only need to remove LUKS and use ext4 only. I’m a bit worried though, about the internal hard disk, glad for any debugging pointers.

UPDATE: disk really works, backup completed. though, every third time I end up with the htaccess error and must plug power with running nextbox. Is there a difference in USB 2/3 ports, how power could be consumed? it worked with the USB 2 port…but I did not do real try and error, obviously I wanted my first backup to complete first :wink:

Nope, just after a power cycle, the issue is that once power drops, the internal hard-drive is kind of deactivated by the OS, thus not easily re-activated again.

Not really aware about the details, but likely there are some differences as I assume they are connected to different USB controllers. You could also try to connect a USB-hub in between minimizing the power draw from the raspberry

This means if I dont have SSH enabled, a hard “power unplug” is always necessary, right? If connected with SSH, can I do a simple reboot?


Yes, this is identical with the reboot inside the NextBox App.

Thanks. Do you have any pointer how to check the internal harddisk’s health?

you could use smartctl from smartmontools to read out the S.M.A.R.T. data for the hard-disk

thanks again, will try.