Touch button (nitrokey fido2) defect?

Can the touch button be defekt?
Just received the nitrokey fido2, but the capacitive button doesn’t work at all.
I only can use the nitrokey for login when removing and pluging the key again.

I tried Windows 10 with latest Opera and firefox (Edge is not supported yet!?).
And also I tried android with chrome.

Frank

Can anybody confirm that it is difficult to hit the capacitiv button?
Is there any special place to press, but I already pressed every point of the key?
Or is mine really defect?
I’m just about to send my nitrokey back!
Regards,
Frank

The correct place to hit the touch sensor is where the touch icon is printed. If this doesn’t work for your as described, it sounds like a defect indeed. Please follow the instructions to return it for a replacement.

Mine seems to be defect as well. I asked for a shipping label (mail request) how long does it take? There was no response until now (few days). Thanks for replie!

I Think I got my return label one day later.
Meanwhile I have my second key, but unfortunately this key is also defect!

Before I ask for an other replacement - is there anybody with a working capacitive button?
Regards,
Frank

1 Like

Similar situation here, I just got replacement keys but they also do not work properly.
Although the replacement key is able to recognize keytouches, it mostly fails. I only get about one working keytouch in dozen failed attempts.

Add: I’m using Kubuntu 19.10. I will return the key, let’s see if there is an improvement.

I received my new key. The button works! :metal: