Touch key not working when plugged into external usb port of case

Hey there,

i just bought a Nitrokey 3A NFC. However i’m not able to use is properly when it is plugged in to the usb ports on top of my case (NZXT Phantom 410). Windows does seem to recognize it but when questioned to touch the button on the key, a touch is never registred / sent back to windows. Unplugging and repluggin it into the same port completes the auth process. I also tried alls four ports (2x USB2, 2x USB3) with the same result. When the Nitrokey ist plugged into a usb port on the mainboard itself it works flawlessly as it does when plugged into my laptop, so i do not suspect a hardware issue. I have never had problems with any other type of hardware with these case-usb-ports. Internally these usb ports are connected to the usb3 header on my mainboard.
Did someone else mabye expierence such an issue as i could not seem to find anything in the faq /forum?
Or is this maybe by design that the Nitrokey does not work with usb hubs of any sort?

Thanks four your help!